CVE-2017-7657 Critical severity vulnerability that affects org.eclipse.jetty:jetty-server
Integer overflow in chunk parsing allows bypassing intermediary authorization checks in specific Jetty configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7657?
CVE-2017-7657 is a critical vulnerability in Debian Debian Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled), transfer-encoding chunks are handled poorly. The chunk length parsing was vulnerable to an integer overflow. Thus a large chunk size could be interpreted as a smaller chunk size and content sent as chunk body could be interpreted as a pipelined request. If Jetty was deployed behind an intermediary that imposed some authorization and that intermediary allowed arbitrarily large chunks to be passed on unchanged, then this flaw could be used to bypass the authorization imposed by the intermediary as the fake pipelined request would not be interpreted by the intermediary as a request.
Which versions are affected by CVE-2017-7657?
4 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 17 products.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.jetty:jetty-server Maven | All versions | 9.2.25.v20180606 |
org.eclipse.jetty:jetty-server Maven | All versions | 9.2.25.v20180606 |
org.eclipse.jetty:jetty-server Maven | From 9.3.0 | 9.3.24.v20180605 |
org.eclipse.jetty:jetty-server Maven | From 9.3.0 | 9.3.24.v20180605 |
Products include Debian Debian Linux, Eclipse Jetty, Hp Xp P9000 Command View, Netapp E-Series Santricity Management, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services and 11 more.
How do I fix CVE-2017-7657?
Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.2.25.v20180606 or 9.3.24.v20180605.
Is CVE-2017-7657 being exploited?
There is no known exploitation of CVE-2017-7657 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-ER01200, DEBIAN-CVE-2017-7657, GHSA-vgg8-72f2-qm23, UBUNTU-CVE-2017-7657.