CVE-2017-7658 Jetty vulnerable to authorization bypass due to inconsistent HTTP request handling (HTTP Request Smuggling)
Attackers can bypass intermediary authorization checks by exploiting HTTP request smuggling via conflicting Content-Length headers in Jetty.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7658?
CVE-2017-7658 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Eclipse Jetty Server, versions 9.2.x and older, 9.3.x (all non HTTP/1.x configurations), and 9.4.x (all HTTP/1.x configurations), when presented with two content-lengths headers, Jetty ignored the second. When presented with a content-length and a chunked encoding header, the content-length was ignored (as per RFC 2616). If an intermediary decided on the shorter length, but still passed on the longer body, then body content could be interpreted by Jetty as a pipelined request. If the intermediary was imposing authorization, the fake pipelined request would bypass that authorization.
Weakness: CWE-444
Which versions are affected by CVE-2017-7658?
6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 19 products.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.jetty:jetty-server Maven | All versions | 9.2.25.v20180606 |
org.eclipse.jetty:jetty-server Maven | All versions | 9.2.25.v20180606 |
org.eclipse.jetty:jetty-server Maven | From 9.3.0 | 9.3.24.v20180605 |
org.eclipse.jetty:jetty-server Maven | From 9.3.0 | 9.3.24.v20180605 |
org.eclipse.jetty:jetty-server Maven | From 9.4.0 | 9.4.11.v20180605 |
org.eclipse.jetty:jetty-server Maven | From 9.4.0 | 9.4.11.v20180605 |
Products include Debian Debian Linux, Eclipse Jetty, Hp Xp P9000 Command View, Netapp E-Series Santricity Management, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services and 13 more.
How do I fix CVE-2017-7658?
Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.2.25.v20180606, 9.3.24.v20180605 or 9.4.11.v20180605.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2017-7658 being exploited?
There is no known exploitation of CVE-2017-7658 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-WA43103, CLSA-2026-1784769583, DEBIAN-CVE-2017-7658, GHSA-6x9x-8qw9-9pp6, UBUNTU-CVE-2017-7658.