# CVE-2017-7658: Jetty vulnerable to authorization bypass due to inconsistent HTTP request handling (HTTP Request Smuggling)

> Attackers can bypass intermediary authorization checks by exploiting HTTP request smuggling via conflicting Content-Length headers in Jetty.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2026-WA43103, CLSA-2026-1784769583, DEBIAN-CVE-2017-7658, GHSA-6x9x-8qw9-9pp6, UBUNTU-CVE-2017-7658

## What is CVE-2017-7658?

CVE-2017-7658 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Jetty Server, versions 9.2.x and older, 9.3.x (all non HTTP/1.x configurations), and 9.4.x (all HTTP/1.x configurations), when presented with two content-lengths headers, Jetty ignored the second. When presented with a content-length and a chunked encoding header, the content-length was ignored (as per RFC 2616). If an intermediary decided on the shorter length, but still passed on the longer body, then body content could be interpreted by Jetty as a pipelined request. If the intermediary was imposing authorization, the fake pipelined request would bypass that authorization.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2017-7658?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 19 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.2.25.v20180606 |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.2.25.v20180606 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.24.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.3.0 | 9.3.24.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.11.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.11.v20180605 |

Products: Debian Debian Linux, Eclipse Jetty, Hp Xp P9000 Command View, Netapp E-Series Santricity Management, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services, Netapp Hci Management Node, Netapp Hci Storage Node, Netapp Oncommand System Manager, Netapp Oncommand Unified Manager for 7-Mode, Netapp Santricity Cloud Connector, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager, Netapp Solidfire, Netapp Storage Services Connector, Oracle Rest Data Services, Oracle Retail Xstore Payment, Oracle Retail Xstore Point of Service.

## How do I fix CVE-2017-7658?

Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.2.25.v20180606, 9.3.24.v20180605 or 9.4.11.v20180605.

## Is CVE-2017-7658 being exploited?

There is no known exploitation of CVE-2017-7658 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7658 and fix it if it is affected.

What it is: CVE-2017-7658 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7658 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.2.25.v20180606
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.2.25.v20180606
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.24.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected from 9.3.0; fixed in 9.3.24.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.11.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.11.v20180605

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7658/ (Markdown: https://insights.sbomify.com/CVE-2017-7658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7658
- OSV: https://osv.dev/vulnerability/CVE-2017-7658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7658/
Summaries are generated and may contain mistakes; the official description above is the record.
