# CVE-2017-7660: Apache Solr insecure inter-node communication

> Attackers can spoof cluster nodes to bypass authentication in Apache Solr when BasicAuth is used without specific interceptor plugins.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-c82r-qg3w-q5mv

## What is CVE-2017-7660?

CVE-2017-7660 is a high-severity authentication bypass vulnerability in Apache Solr, published on 7 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Solr uses a PKI based mechanism to secure inter-node communication when security is enabled. It is possible to create a specially crafted node name that does not exist as part of the cluster and point it to a malicious node. This can trick the nodes in cluster to believe that the malicious node is a member of the cluster. So, if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin or if the user has implemented a custom Authentication plugin, which does not implement either "HttpClientInterceptorPlugin" or "HttpClientBuilderPlugin", his/her servers are vulnerable to this attack. Users who only use SSL without basic authentication or those who use Kerberos are not affected.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-7660?

4 open source packages ship an affected version, including org.apache.solr:solr-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | From 5.3.0 | 5.5.5 |
| `org.apache.solr:solr-core` | Maven | From 5.3.0 | 5.5.5 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 6.6.0 |
| `org.apache.solr:solr-core` | Maven | From 6.0.0 | 6.6.0 |

Products: Apache Solr.

## How do I fix CVE-2017-7660?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 5.5.5 or 6.6.0.

## Is CVE-2017-7660 being exploited?

There is no known exploitation of CVE-2017-7660 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7660 and fix it if it is affected.

What it is: CVE-2017-7660 is a high-severity authentication bypass vulnerability in Apache Solr, published on 7 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7660 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected from 5.3.0; fixed in 5.5.5
- org.apache.solr:solr-core (Maven): affected from 5.3.0; fixed in 5.5.5
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 6.6.0
- org.apache.solr:solr-core (Maven): affected from 6.0.0; fixed in 6.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7660/ (Markdown: https://insights.sbomify.com/CVE-2017-7660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7660
- OSV: https://osv.dev/vulnerability/CVE-2017-7660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7660/
Summaries are generated and may contain mistakes; the official description above is the record.
