# CVE-2017-7661: Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, and org.apache.cxf.fediz:fediz-spring2

> A CSRF vulnerability in Apache CXF Fediz plugins allows attackers to bypass security controls, requiring an upgrade to secure the application.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-whw7-h25v-9qvx

## What is CVE-2017-7661?

CVE-2017-7661 is a high-severity vulnerability in Apache CXF Fediz, published on 16 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache CXF Fediz ships with a number of container-specific plugins to enable WS-Federation for applications. A CSRF (Cross Style Request Forgery) style vulnerability has been found in the Spring 2, Spring 3, Jetty 8 and Jetty 9 plugins in Apache CXF Fediz prior to 1.4.0, 1.3.2 and 1.2.4.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-7661?

8 open source packages ship an affected version, including org.apache.cxf.fediz:fediz-spring2, org.apache.cxf.fediz:fediz-jetty8 and org.apache.cxf.fediz:fediz-jetty9. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cxf.fediz:fediz-spring2` | Maven | All versions | 1.2.4 |
| `org.apache.cxf.fediz:fediz-spring2` | Maven | All versions | 1.2.4 |
| `org.apache.cxf.fediz:fediz-spring2` | Maven | From 1.3.0 | 1.3.2 |
| `org.apache.cxf.fediz:fediz-spring2` | Maven | From 1.3.0 | 1.3.2 |
| `org.apache.cxf.fediz:fediz-jetty8` | Maven | All versions | 1.3.2 |
| `org.apache.cxf.fediz:fediz-jetty8` | Maven | All versions | 1.3.2 |
| `org.apache.cxf.fediz:fediz-jetty9` | Maven | All versions | 1.3.2 |
| `org.apache.cxf.fediz:fediz-jetty9` | Maven | All versions | 1.3.2 |

Products: Apache Cxf Fediz.

## How do I fix CVE-2017-7661?

Upgrade org.apache.cxf.fediz:fediz-spring2 to a fixed version for your release line: 1.2.4 or 1.3.2.

## Is CVE-2017-7661 being exploited?

There is no known exploitation of CVE-2017-7661 in the wild and no public exploit code.

## Other vulnerabilities in Apache CXF Fediz

- [CVE-2016-4464](https://insights.sbomify.com/CVE-2016-4464/): High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2 (critical 9.8)
- [CVE-2017-12631](https://insights.sbomify.com/CVE-2017-12631/): Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3 (high 8.8)
- [CVE-2017-7662](https://insights.sbomify.com/CVE-2017-7662/): Cross-Site Request Forgery in Apache CXF Fediz (high 8.8)
- [CVE-2018-8038](https://insights.sbomify.com/CVE-2018-8038/): High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3 (high 7.5)
- [CVE-2015-5175](https://insights.sbomify.com/CVE-2015-5175/): Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7661 and fix it if it is affected.

What it is: CVE-2017-7661 is a high-severity vulnerability in Apache CXF Fediz, published on 16 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7661 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cxf.fediz:fediz-spring2 (Maven): affected all versions; fixed in 1.2.4
- org.apache.cxf.fediz:fediz-spring2 (Maven): affected all versions; fixed in 1.2.4
- org.apache.cxf.fediz:fediz-spring2 (Maven): affected from 1.3.0; fixed in 1.3.2
- org.apache.cxf.fediz:fediz-spring2 (Maven): affected from 1.3.0; fixed in 1.3.2
- org.apache.cxf.fediz:fediz-jetty8 (Maven): affected all versions; fixed in 1.3.2
- org.apache.cxf.fediz:fediz-jetty8 (Maven): affected all versions; fixed in 1.3.2
- org.apache.cxf.fediz:fediz-jetty9 (Maven): affected all versions; fixed in 1.3.2
- org.apache.cxf.fediz:fediz-jetty9 (Maven): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7661/ (Markdown: https://insights.sbomify.com/CVE-2017-7661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7661
- OSV: https://osv.dev/vulnerability/CVE-2017-7661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7661/
Summaries are generated and may contain mistakes; the official description above is the record.
