CVE-2017-7665 Cross-site Scripting in Apache NiFi

Medium 6.1 Published Updated

Insufficient XSS protection in Apache NiFi UI components allows attackers to execute scripts, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-7665?

CVE-2017-7665 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 12 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Weakness: CWE-79

Which versions are affected by CVE-2017-7665?

4 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.

PackageAffectedFixed in
org.apache.nifi:nifi MavenAll versions0.7.4
org.apache.nifi:nifi MavenAll versions0.7.4
org.apache.nifi:nifi MavenFrom 1.0.01.3.0
org.apache.nifi:nifi MavenFrom 1.0.01.3.0

Products include Apache Nifi.

How do I fix CVE-2017-7665?

Upgrade org.apache.nifi:nifi to a fixed version for your release line: 0.7.4 or 1.3.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-7665 being exploited?

There is no known exploitation of CVE-2017-7665 in the wild and no public exploit code.

All Apache Nifi vulnerabilities

Sources

Also known as GHSA-m5r7-w9v3-ghmx.

Is CVE-2017-7665 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free