# CVE-2017-7665: Cross-site Scripting in Apache NiFi

> Insufficient XSS protection in Apache NiFi UI components allows attackers to execute scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m5r7-w9v3-ghmx

## What is CVE-2017-7665?

CVE-2017-7665 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 12 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-7665?

4 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi` | Maven | All versions | 0.7.4 |
| `org.apache.nifi:nifi` | Maven | All versions | 0.7.4 |
| `org.apache.nifi:nifi` | Maven | From 1.0.0 | 1.3.0 |
| `org.apache.nifi:nifi` | Maven | From 1.0.0 | 1.3.0 |

Products: Apache Nifi.

## How do I fix CVE-2017-7665?

Upgrade org.apache.nifi:nifi to a fixed version for your release line: 0.7.4 or 1.3.0.

## Is CVE-2017-7665 being exploited?

There is no known exploitation of CVE-2017-7665 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7665 and fix it if it is affected.

What it is: CVE-2017-7665 is a medium-severity cross-site scripting vulnerability in Apache Nifi, published on 12 Jun 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7665 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi (Maven): affected all versions; fixed in 0.7.4
- org.apache.nifi:nifi (Maven): affected all versions; fixed in 0.7.4
- org.apache.nifi:nifi (Maven): affected from 1.0.0; fixed in 1.3.0
- org.apache.nifi:nifi (Maven): affected from 1.0.0; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7665/ (Markdown: https://insights.sbomify.com/CVE-2017-7665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7665
- OSV: https://osv.dev/vulnerability/CVE-2017-7665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7665/
Summaries are generated and may contain mistakes; the official description above is the record.
