CVE-2017-7667 Origin Validation Error in Apache NiFi
Missing X-Frame-Options header in Apache NiFi allows clickjacking attacks by permitting cross-origin framing.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7667?
CVE-2017-7667 is a high-severity vulnerability in Apache Nifi, published on 12 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache NiFi before 0.7.4 and 1.x before 1.3.0 need to establish the response header telling browsers to only allow framing with the same origin.
Weakness: CWE-346
Which versions are affected by CVE-2017-7667?
4 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.nifi:nifi Maven | All versions | 0.7.4 |
org.apache.nifi:nifi Maven | All versions | 0.7.4 |
org.apache.nifi:nifi Maven | From 1.0.0 | 1.3.0 |
org.apache.nifi:nifi Maven | From 1.0.0 | 1.3.0 |
Products include Apache Nifi.
How do I fix CVE-2017-7667?
Upgrade org.apache.nifi:nifi to a fixed version for your release line: 0.7.4 or 1.3.0.
Is CVE-2017-7667 being exploited?
There is no known exploitation of CVE-2017-7667 in the wild and no public exploit code.
Other vulnerabilities in Apache Nifi
- CVE-2018-1309 Improper Restriction of XML External Entity Reference in Apache NiFi
- CVE-2017-15697 Apache NiFi XSS issue in context path handling
- CVE-2017-5636 Injection in Apache NiFi
- CVE-2026-68981 Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests
- CVE-2023-36542 Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources
Sources
Also known as GHSA-jvx9-rj3w-jq99.