CVE-2017-7672 Apache Struts Improper Input Validation vulnerability

Medium 5.9 Published Updated

An attacker can cause a denial of service by submitting a specially crafted URL to a form field using the built-in URLValidator in Apache Struts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-7672?

CVE-2017-7672 is a medium-severity denial of service vulnerability in Apache Struts, published on 13 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. Solution is to upgrade to Apache Struts version 2.5.12.

Weakness: CWE-20

Which versions are affected by CVE-2017-7672?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.

PackageAffectedFixed in
org.apache.struts:struts2-core MavenFrom 2.5.02.5.12
org.apache.struts:struts2-core MavenFrom 2.5.02.5.12

Products include Apache Struts.

How do I fix CVE-2017-7672?

Upgrade org.apache.struts:struts2-core to 2.5.12 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2017-7672 being exploited?

There is no known exploitation of CVE-2017-7672 in the wild and no public exploit code.

All Apache Struts vulnerabilities

Sources

Also known as GHSA-9gp7-jvm2-r4mx.

Is CVE-2017-7672 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free