{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7673 in the wild and no public exploit code.","fix":"Upgrade org.apache.openmeetings:openmeetings-parent to 3.3.0 or later.","what":"CVE-2017-7673 is a critical vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7673 and fix it if it is affected.\n\nWhat it is: CVE-2017-7673 is a critical vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7673 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 1.0.0; fixed in 3.3.0\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 1.0.0; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7673/ (Markdown: https://insights.sbomify.com/CVE-2017-7673/index.md)","id":"CVE-2017-7673","markdown":"https://insights.sbomify.com/CVE-2017-7673/index.md","name":"CVE-2017-7673","record":{"aliases":["GHSA-cqm6-hrgq-6869"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenMeetings","requires_auth":"none","summary":"Weak cryptographic storage and missing brute force protections in Apache OpenMeetings allow attackers to bypass security controls and potentially take over accounts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"openmeetings","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-326","name":"Inadequate Encryption Strength"},{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"Apache OpenMeetings 1.0.0 uses not very strong cryptographic storage, captcha is not used in registration and forget password dialogs and auth forms missing brute force protection.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache OpenMeetings has Inadequate Encryption Strength","id":"CVE-2017-7673","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Insufficient Verification of Data Authenticity in Apache Tomcat","id":"CVE-2017-7674"},"packages":[{"ecosystem":"Maven","fixed":["3.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":null,"source":"GHSA-cqm6-hrgq-6869"},{"ecosystem":"Maven","fixed":["3.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":"pkg:maven/org.apache.openmeetings/openmeetings-parent","source":"GHSA-cqm6-hrgq-6869"}],"prev":{"headline":"Apache Struts Improper Input Validation vulnerability","id":"CVE-2017-7672"},"products":["Apache OpenMeetings"],"published":"2017-07-14","related":[{"cvss_score":10,"headline":"Apache OpenMeetings does not correctly validate uploaded XML documents","id":"CVE-2017-7664","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: Deserialisation of untrusted data in cluster mode","id":"CVE-2024-54676","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: allows user impersonation","id":"CVE-2023-28326","kev_date_added":null,"published":"2023-03-28"},{"cvss_score":9.8,"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736","kev_date_added":null,"published":"2017-10-12"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to Cross-Site Request Forgery","id":"CVE-2017-7666","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681","kev_date_added":null,"published":"2017-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Apache Software Foundation"]},"summary":"Weak cryptographic storage and missing brute force protections in Apache OpenMeetings allow attackers to bypass security controls and potentially take over accounts.","url":"https://insights.sbomify.com/CVE-2017-7673/"}