# CVE-2017-7678: Moderate severity vulnerability that affects org.apache.spark:spark-core_2.10 and org.apache.spark:spark-core_2.11

> Attackers can trick users into executing malicious scripts via reflected XSS in Apache Spark web UIs, potentially compromising client systems.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-r34r-f84j-5x4x

## What is CVE-2017-7678?

CVE-2017-7678 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache Spark before 2.2.0, it is possible for an attacker to take advantage of a user's trust in the server to trick them into visiting a link that points to a shared Spark cluster and submits data including MHTML to the Spark master, or history server. This data, which could contain a script, would then be reflected back to the user and could be evaluated and executed by MS Windows-based clients. It is not an attack on Spark itself, but on the user, who may then execute the script inadvertently when viewing elements of the Spark web UIs.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-7678?

4 open source packages ship an affected version, including org.apache.spark:spark-core_2.10 and org.apache.spark:spark-core_2.11. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core_2.10` | Maven | All versions | 2.2.0 |
| `org.apache.spark:spark-core_2.10` | Maven | All versions | 2.2.0 |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | 2.2.0 |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | 2.2.0 |

Products: Apache Spark.

## How do I fix CVE-2017-7678?

Upgrade org.apache.spark:spark-core_2.10 to 2.2.0 or later.

## Is CVE-2017-7678 being exploited?

There is no known exploitation of CVE-2017-7678 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7678 and fix it if it is affected.

What it is: CVE-2017-7678 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7678 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core_2.10 (Maven): affected all versions; fixed in 2.2.0
- org.apache.spark:spark-core_2.10 (Maven): affected all versions; fixed in 2.2.0
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.2.0
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7678/ (Markdown: https://insights.sbomify.com/CVE-2017-7678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7678
- OSV: https://osv.dev/vulnerability/CVE-2017-7678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7678/
Summaries are generated and may contain mistakes; the official description above is the record.
