{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7682 in the wild and no public exploit code.","fix":"Upgrade org.apache.openmeetings:openmeetings-parent to 3.3.0 or later.","what":"CVE-2017-7682 is a high-severity missing authorization vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7682 and fix it if it is affected.\n\nWhat it is: CVE-2017-7682 is a high-severity missing authorization vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7682 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.2.0; fixed in 3.3.0\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 3.2.0; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7682/ (Markdown: https://insights.sbomify.com/CVE-2017-7682/index.md)","id":"CVE-2017-7682","markdown":"https://insights.sbomify.com/CVE-2017-7682/index.md","name":"CVE-2017-7682","record":{"aliases":["GHSA-2q65-xxg6-3qh5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenMeetings","requires_auth":"none","summary":"Attackers can manipulate parameters to access restricted areas in Apache OpenMeetings, potentially reading or modifying unauthorized data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"openmeetings","vendor":"apache"}],"cvss":{"score":8.2,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.0"},"cwes":[],"description":"Apache OpenMeetings 3.2.0 is vulnerable to parameter manipulation attacks, as a result attacker has access to restricted areas.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache OpenMeetings vulnerable to parameter manipulation attacks","id":"CVE-2017-7682","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Apache OpenMeetings displays Tomcat version and detailed error stack trace","id":"CVE-2017-7683"},"packages":[{"ecosystem":"Maven","fixed":["3.3.0"],"introduced":["3.2.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":null,"source":"GHSA-2q65-xxg6-3qh5"},{"ecosystem":"Maven","fixed":["3.3.0"],"introduced":["3.2.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":"pkg:maven/org.apache.openmeetings/openmeetings-parent","source":"GHSA-2q65-xxg6-3qh5"}],"prev":{"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681"},"products":["Apache OpenMeetings"],"published":"2017-07-14","related":[{"cvss_score":10,"headline":"Apache OpenMeetings does not correctly validate uploaded XML documents","id":"CVE-2017-7664","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: Deserialisation of untrusted data in cluster mode","id":"CVE-2024-54676","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: allows user impersonation","id":"CVE-2023-28326","kev_date_added":null,"published":"2023-03-28"},{"cvss_score":9.8,"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736","kev_date_added":null,"published":"2017-10-12"},{"cvss_score":9.8,"headline":"Apache OpenMeetings has Inadequate Encryption Strength","id":"CVE-2017-7673","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to Cross-Site Request Forgery","id":"CVE-2017-7666","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681","kev_date_added":null,"published":"2017-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can manipulate parameters to access restricted areas in Apache OpenMeetings, potentially reading or modifying unauthorized data.","url":"https://insights.sbomify.com/CVE-2017-7682/"}