# CVE-2017-7683: Apache OpenMeetings displays Tomcat version and detailed error stack trace

> Apache OpenMeetings exposes Tomcat version and stack traces, allowing attackers to gather sensitive system information for further exploitation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4v67-wg88-37p9

## What is CVE-2017-7683?

CVE-2017-7683 is a high-severity vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache OpenMeetings 1.0.0 displays Tomcat version and detailed error stack trace, which is not secure.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-7683?

2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.openmeetings:openmeetings-parent` | Maven | From 1.0.0 | 3.3.0 |
| `org.apache.openmeetings:openmeetings-parent` | Maven | From 1.0.0 | 3.3.0 |

Products: Apache Openmeetings.

## How do I fix CVE-2017-7683?

Upgrade org.apache.openmeetings:openmeetings-parent to 3.3.0 or later.

## Is CVE-2017-7683 being exploited?

There is no known exploitation of CVE-2017-7683 in the wild and no public exploit code.

## Other vulnerabilities in Apache OpenMeetings

- [CVE-2017-7664](https://insights.sbomify.com/CVE-2017-7664/): Apache OpenMeetings does not correctly validate uploaded XML documents (critical 10.0)
- [CVE-2024-54676](https://insights.sbomify.com/CVE-2024-54676/): Apache OpenMeetings: Deserialisation of untrusted data in cluster mode (critical 9.8)
- [CVE-2023-28326](https://insights.sbomify.com/CVE-2023-28326/): Apache OpenMeetings: allows user impersonation (critical 9.8)
- [CVE-2016-8736](https://insights.sbomify.com/CVE-2016-8736/): Apache OpenMeetings RCE (critical 9.8)
- [CVE-2017-7673](https://insights.sbomify.com/CVE-2017-7673/): Apache OpenMeetings has Inadequate Encryption Strength (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7683 and fix it if it is affected.

What it is: CVE-2017-7683 is a high-severity vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7683 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.openmeetings:openmeetings-parent (Maven): affected from 1.0.0; fixed in 3.3.0
- org.apache.openmeetings:openmeetings-parent (Maven): affected from 1.0.0; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7683/ (Markdown: https://insights.sbomify.com/CVE-2017-7683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7683
- OSV: https://osv.dev/vulnerability/CVE-2017-7683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7683/
Summaries are generated and may contain mistakes; the official description above is the record.
