{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-parent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-7685 in the wild and no public exploit code.","fix":"Upgrade org.apache.openmeetings:openmeetings-parent to 3.3.0 or later.","what":"CVE-2017-7685 is a medium-severity vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-7685 and fix it if it is affected.\n\nWhat it is: CVE-2017-7685 is a medium-severity vulnerability in Apache OpenMeetings, published on 14 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-7685 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 1.0.0; fixed in 3.3.0\n- org.apache.openmeetings:openmeetings-parent (Maven): affected from 1.0.0; fixed in 3.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-7685/ (Markdown: https://insights.sbomify.com/CVE-2017-7685/index.md)","id":"CVE-2017-7685","markdown":"https://insights.sbomify.com/CVE-2017-7685/index.md","name":"CVE-2017-7685","record":{"aliases":["GHSA-2c3p-9j5f-33g3"],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenMeetings","requires_auth":"none","summary":"Apache OpenMeetings allows insecure HTTP methods, potentially enabling unauthorized actions or bypassing security controls.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"openmeetings","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[],"description":"Apache OpenMeetings 1.0.0 responds to the following insecure HTTP methods: PUT, DELETE, HEAD, and PATCH.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache OpenMeetings responds to insecure HTTP methods","id":"CVE-2017-7685","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"misconfiguration","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Ignite communicates to an external PHP server where sensitive information is sent","id":"CVE-2017-7686"},"packages":[{"ecosystem":"Maven","fixed":["3.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":null,"source":"GHSA-2c3p-9j5f-33g3"},{"ecosystem":"Maven","fixed":["3.3.0"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-parent","purl":"pkg:maven/org.apache.openmeetings/openmeetings-parent","source":"GHSA-2c3p-9j5f-33g3"}],"prev":{"headline":"Apache OpenMeetings vulnerable to Uncontrolled Resource Consumption","id":"CVE-2017-7684"},"products":["Apache OpenMeetings"],"published":"2017-07-14","related":[{"cvss_score":10,"headline":"Apache OpenMeetings does not correctly validate uploaded XML documents","id":"CVE-2017-7664","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: Deserialisation of untrusted data in cluster mode","id":"CVE-2024-54676","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: allows user impersonation","id":"CVE-2023-28326","kev_date_added":null,"published":"2023-03-28"},{"cvss_score":9.8,"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736","kev_date_added":null,"published":"2017-10-12"},{"cvss_score":9.8,"headline":"Apache OpenMeetings has Inadequate Encryption Strength","id":"CVE-2017-7673","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to Cross-Site Request Forgery","id":"CVE-2017-7666","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681","kev_date_added":null,"published":"2017-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Apache OpenMeetings allows insecure HTTP methods, potentially enabling unauthorized actions or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2017-7685/"}