CVE-2017-7687 Denial of service in Apache Mesos
A malicious actor can cause a denial of service in Apache Mesos masters by sending a malformed URL path, rendering the cluster inoperable.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-7687?
CVE-2017-7687 is a high-severity denial of service vulnerability in Apache Mesos, published on 28 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When handling a decoding failure for a malformed URL path of an HTTP request, libprocess in Apache Mesos before 1.1.3, 1.2.x before 1.2.2, 1.3.x before 1.3.1, and 1.4.0-dev might crash because the code accidentally calls inappropriate function. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Which versions are affected by CVE-2017-7687?
6 open source packages ship an affected version, including org.apache.mesos:mesos. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.mesos:mesos Maven | All versions | 1.1.3 |
org.apache.mesos:mesos Maven | All versions | 1.1.3 |
org.apache.mesos:mesos Maven | From 1.2.0 | 1.2.2 |
org.apache.mesos:mesos Maven | From 1.2.0 | 1.2.2 |
org.apache.mesos:mesos Maven | From 1.3.0 | 1.3.1 |
org.apache.mesos:mesos Maven | From 1.3.0 | 1.3.1 |
Products include Apache Mesos.
How do I fix CVE-2017-7687?
Upgrade org.apache.mesos:mesos to a fixed version for your release line: 1.1.3, 1.2.2 or 1.3.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-7687 being exploited?
There is no known exploitation of CVE-2017-7687 in the wild and no public exploit code.
Other vulnerabilities in Apache Mesos
Sources
Also known as GHSA-x869-784m-jmj2.