# CVE-2017-7723: Cross-site scripting in n/a

> Cross-site scripting in Easy WP SMTP allows attackers to inject malicious scripts via email subject or body fields.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 24 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v833-m27m-8pfh

## What is CVE-2017-7723?

CVE-2017-7723 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XSS exists in Easy WP SMTP (before 1.2.5), a WordPress Plugin, via the e-mail subject or body.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-7723?

It affects 1 product.


Products: Wp-Ecommerce Easy Wp Smtp.

## How do I fix CVE-2017-7723?

No fix has been published for CVE-2017-7723 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-7723 being exploited?

There is no known exploitation of CVE-2017-7723 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-25141](https://insights.sbomify.com/CVE-2019-25141/): Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update (critical 9.8)
- [CVE-2022-42699](https://insights.sbomify.com/CVE-2022-42699/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Remote Code Execution (RCE) (critical 9.1)
- [CVE-2022-45829](https://insights.sbomify.com/CVE-2022-45829/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Arbitrary File Deletion (high 8.7)
- [CVE-2020-35234](https://insights.sbomify.com/CVE-2020-35234/): Information disclosure in n/a (high 7.5)
- [CVE-2022-3334](https://insights.sbomify.com/CVE-2022-3334/): Easy WP SMTP < 1.5.0 - Admin+ PHP Objection Injection (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7723 and fix it if it is affected.

What it is: CVE-2017-7723 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-7723 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7723/ (Markdown: https://insights.sbomify.com/CVE-2017-7723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7723
- OSV: https://osv.dev/vulnerability/CVE-2017-7723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7723/
Summaries are generated and may contain mistakes; the official description above is the record.
