# CVE-2017-7957: Denial of service in XStream

> Attackers can crash applications using XStream by sending XML that attempts to instantiate the void primitive type, requiring a specific workaround to be absent.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2017
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2017-7957, DLA-930-1, DSA-3841-1, GHSA-7hwc-46rm-65jh, SUSE-RU-2019:1006-1, SUSE-SU-2017:3389-1, SUSE-SU-2017:3390-1, SUSE-SU-2019:1006-1, UBUNTU-CVE-2017-7957

## What is CVE-2017-7957?

CVE-2017-7957 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 29 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XStream through 1.4.9, when a certain denyTypes workaround is not used, mishandles attempts to create an instance of the primitive type 'void' during unmarshalling, leading to a remote application crash, as demonstrated by an xstream.fromXML("<void/>") call.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-7957?

2 open source packages ship an affected version, including com.thoughtworks.xstream:xstream. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.10 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.10 |
| `spacewalk-backend` | SUSE:Manager Proxy 3.2 | All versions | 2.8.57.14-3.25.3 |
| `spacewalk-backend` | SUSE:Manager Proxy 3.2 | All versions | 2.8.57.14-3.25.3 |
| `spacewalk-certs-tools` | SUSE:Manager Proxy 3.2 | All versions | 2.8.8.7-3.6.3 |
| `spacewalk-certs-tools` | SUSE:Manager Proxy 3.2 | All versions | 2.8.8.7-3.6.3 |
| `spacewalk-web` | SUSE:Manager Proxy 3.2 | All versions | 2.8.7.15-3.24.3 |
| `spacewalk-web` | SUSE:Manager Proxy 3.2 | All versions | 2.8.7.15-3.24.3 |
| `xstream` | SUSE:Manager Server 3.0 | All versions | 1.4.9-4.3.1 |
| `xstream` | SUSE:Manager Server 3.1 | All versions | 1.4.9-3.3.1 |
| `apache-commons-lang3` | SUSE:Manager Server 3.2 | All versions | 3.4-3.3.3 |
| `apache-commons-lang3` | SUSE:Manager Server 3.2 | All versions | 3.4-3.3.3 |
| `cobbler` | SUSE:Manager Server 3.2 | All versions | 2.6.6-6.16.3 |
| `cobbler` | SUSE:Manager Server 3.2 | All versions | 2.6.6-6.16.3 |
| `drools` | SUSE:Manager Server 3.2 | All versions | 7.17.0-3.3.3 |
| `drools` | SUSE:Manager Server 3.2 | All versions | 7.17.0-3.3.3 |
| `guava` | SUSE:Manager Server 3.2 | All versions | 27.0.1-3.3.3 |
| `guava` | SUSE:Manager Server 3.2 | All versions | 27.0.1-3.3.3 |
| `jade4j` | SUSE:Manager Server 3.2 | All versions | 1.0.7-3.3.3 |
| `jade4j` | SUSE:Manager Server 3.2 | All versions | 1.0.7-3.3.3 |
| `kie-api` | SUSE:Manager Server 3.2 | All versions | 7.17.0-3.3.3 |
| `kie-api` | SUSE:Manager Server 3.2 | All versions | 7.17.0-3.3.3 |
| `kie-soup` | SUSE:Manager Server 3.2 | All versions | 7.17.0.Final-2.3.3 |
| `kie-soup` | SUSE:Manager Server 3.2 | All versions | 7.17.0.Final-2.3.3 |
| `optaplanner` | SUSE:Manager Server 3.2 | All versions | 7.17.0-3.3.3 |
| `optaplanner` | SUSE:Manager Server 3.2 | All versions | 7.17.0-3.3.3 |
| `py26-compat-salt` | SUSE:Manager Server 3.2 | All versions | 2016.11.10-6.21.3 |
| `py26-compat-salt` | SUSE:Manager Server 3.2 | All versions | 2016.11.10-6.21.3 |
| `reprepro` | SUSE:Manager Server 3.2 | All versions | 5.3.0-2.3.3 |
| `reprepro` | SUSE:Manager Server 3.2 | All versions | 5.3.0-2.3.3 |
| `smdba` | SUSE:Manager Server 3.2 | All versions | 1.6.4-0.3.9.3 |
| `smdba` | SUSE:Manager Server 3.2 | All versions | 1.6.4-0.3.9.3 |
| `spacecmd` | SUSE:Manager Server 3.2 | All versions | 2.8.25.10-3.20.3 |
| `spacecmd` | SUSE:Manager Server 3.2 | All versions | 2.8.25.10-3.20.3 |
| `spacewalk-admin` | SUSE:Manager Server 3.2 | All versions | 2.8.4.4-3.6.3 |
| `spacewalk-admin` | SUSE:Manager Server 3.2 | All versions | 2.8.4.4-3.6.3 |
| `spacewalk-backend` | SUSE:Manager Server 3.2 | All versions | 2.8.57.14-3.25.3 |
| `spacewalk-backend` | SUSE:Manager Server 3.2 | All versions | 2.8.57.14-3.25.3 |
| `spacewalk-branding` | SUSE:Manager Server 3.2 | All versions | 2.8.5.15-3.19.3 |
| `spacewalk-branding` | SUSE:Manager Server 3.2 | All versions | 2.8.5.15-3.19.3 |

Products: Debian Debian Linux, Redhat Fuse, Redhat Jboss Middleware, Xstream Xstream.

## How do I fix CVE-2017-7957?

Upgrade com.thoughtworks.xstream:xstream to 1.4.10 or later.

## Is CVE-2017-7957 being exploited?

There is no known exploitation of CVE-2017-7957 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-7957 and fix it if it is affected.

What it is: CVE-2017-7957 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 29 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-7957 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.10
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-7957/ (Markdown: https://insights.sbomify.com/CVE-2017-7957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-7957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-7957
- OSV: https://osv.dev/vulnerability/CVE-2017-7957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-7957/
Summaries are generated and may contain mistakes; the official description above is the record.
