CVE-2017-7983 Information disclosure in n/a
Joomla leaks PHPMailer version in email headers, exposing internal library details to attackers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2017-7983?
CVE-2017-7983 is a medium-severity vulnerability in Joomla Joomla\!, published on 25 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Joomla! 1.5.0 through 3.6.5 (fixed in 3.7.0), mail sent using the JMail API leaked the used PHPMailer version in the mail headers.
Weakness: CWE-200
Which versions are affected by CVE-2017-7983?
It affects 1 product.
Products include Joomla Joomla\!.
How do I fix CVE-2017-7983?
No fix has been published for CVE-2017-7983 yet. Limit exposure of the affected software until one is available.
Is CVE-2017-7983 being exploited?
There is no known exploitation of CVE-2017-7983 in the wild and no public exploit code.
Other vulnerabilities in Joomla Joomla\!
- CVE-2016-10033 PHPMailer Command Injection
- CVE-2023-23752 Joomla! Improper Access Control
- CVE-2026-48902 Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links
- CVE-2025-25226 [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package
- CVE-2022-23795 [20220303] - Core - User row are not bound to a authentication mechanism
Sources
Also known as GHSA-hhqj-m4pc-9w3p.