CVE-2017-7987 Cross-site scripting in n/a
Attackers can execute arbitrary scripts via XSS in the Joomla template manager due to inadequate escaping of file and folder names.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2017-7987?
CVE-2017-7987 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 25 Apr 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Joomla! 3.2.0 through 3.6.5 (fixed in 3.7.0), inadequate escaping of file and folder names leads to XSS vulnerabilities in the template manager component.
Weakness: CWE-79
Which versions are affected by CVE-2017-7987?
It affects 1 product.
Products include Joomla Joomla\!.
How do I fix CVE-2017-7987?
No fix has been published for CVE-2017-7987 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-7987 being exploited?
There is no known exploitation of CVE-2017-7987 in the wild and no public exploit code.
Other vulnerabilities in Joomla Joomla\!
- CVE-2016-10033 PHPMailer Command Injection
- CVE-2023-23752 Joomla! Improper Access Control
- CVE-2026-48902 Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links
- CVE-2025-25226 [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package
- CVE-2022-23795 [20220303] - Core - User row are not bound to a authentication mechanism
Sources
Also known as GHSA-hjw7-2339-8v84.