# CVE-2017-8028: Improper Authentication in Pivotal Spring-LDAP

> Attackers can bypass authentication with arbitrary passwords if specific LDAP configurations are used, allowing unauthorized access.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DLA-1180-1, DSA-4046-1, GHSA-pjqh-2jcc-5j84, MGASA-2018-0235, UBUNTU-CVE-2017-8028

## What is CVE-2017-8028?

CVE-2017-8028 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Pivotal Spring-LDAP versions 1.3.0 - 2.3.1, when connected to some LDAP servers, when no additional attributes are bound, and when using LDAP BindAuthenticator with org.springframework.ldap.core.support.DefaultTlsDirContextAuthenticationStrategy as the authentication strategy, and setting userSearch, authentication is allowed with an arbitrary password when the username is correct. This occurs because some LDAP vendors require an explicit operation for the LDAP bind to take effect.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-8028?

2 open source packages ship an affected version, including org.springframework.ldap:spring-ldap-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.ldap:spring-ldap-core` | Maven | From 1.3.0 | 2.3.2 |
| `org.springframework.ldap:spring-ldap-core` | Maven | From 1.3.0 | 2.3.2 |

Products: Debian Debian Linux, Pivotal Software Spring-Ldap.

## How do I fix CVE-2017-8028?

Upgrade org.springframework.ldap:spring-ldap-core to 2.3.2 or later.

## Is CVE-2017-8028 being exploited?

There is no known exploitation of CVE-2017-8028 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8028 and fix it if it is affected.

What it is: CVE-2017-8028 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 27 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8028 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.ldap:spring-ldap-core (Maven): affected from 1.3.0; fixed in 2.3.2
- org.springframework.ldap:spring-ldap-core (Maven): affected from 1.3.0; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8028/ (Markdown: https://insights.sbomify.com/CVE-2017-8028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8028
- OSV: https://osv.dev/vulnerability/CVE-2017-8028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8028/
Summaries are generated and may contain mistakes; the official description above is the record.
