CVE-2017-8031 Cloud Foundry UAA Denial of Service through client token revocation endpoint
Authenticated users can revoke other users' tokens in Cloud Foundry UAA under specific token configurations, causing denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-8031?
CVE-2017-8031 is a medium-severity missing authorization vulnerability in cf-release and UAA cf-release: All versions prior to v279, UAA: 30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1, published on 27 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Cloud Foundry Foundation cf-release (all versions prior to v279) and UAA (30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1). In some cases, the UAA allows an authenticated user for a particular client to revoke client tokens for other users on the same client. This occurs only if the client is using opaque tokens or JWT tokens validated using the check_token endpoint. A malicious actor could cause denial of service.
Which versions are affected by CVE-2017-8031?
6 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 3.20.1 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 3.20.1 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.0.0 | 4.5.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.0.0 | 4.5.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.6.0 | 4.7.1 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.6.0 | 4.7.1 |
Products include Cloudfoundry Cf-Release, Cloudfoundry Uaa-Release.
How do I fix CVE-2017-8031?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.20.1, 4.5.3 or 4.7.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2017-8031 being exploited?
There is no known exploitation of CVE-2017-8031 in the wild and no public exploit code.
Other vulnerabilities in cf-release and UAA cf-release: All versions prior to v279, UAA: 30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1
- CVE-2015-5171 Cloud Foundry Runtime Insufficient Session Expiration vulnerability
- CVE-2015-5172 Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password
- CVE-2016-8218 Auth bypass in Cloud Foundry
- CVE-2017-4992 Cloud Foundry UAA privilege escalation with user invitations
- CVE-2016-6658 Information disclosure in n/a
Sources
Also known as GHSA-j4p3-2m2h-cv5f.