# CVE-2017-8031: Cloud Foundry UAA Denial of Service through client token revocation endpoint

> Authenticated users can revoke other users' tokens in Cloud Foundry UAA under specific token configurations, causing denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j4p3-2m2h-cv5f

## What is CVE-2017-8031?

CVE-2017-8031 is a medium-severity missing authorization vulnerability in cf-release and UAA cf-release: All versions prior to v279, UAA: 30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1, published on 27 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Cloud Foundry Foundation cf-release (all versions prior to v279) and UAA (30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1). In some cases, the UAA allows an authenticated user for a particular client to revoke client tokens for other users on the same client. This occurs only if the client is using opaque tokens or JWT tokens validated using the check_token endpoint. A malicious actor could cause denial of service.

## Which versions are affected by CVE-2017-8031?

6 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.20.1 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.20.1 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.0.0 | 4.5.3 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.0.0 | 4.5.3 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.6.0 | 4.7.1 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.6.0 | 4.7.1 |

Products: Cloudfoundry Cf-Release, Cloudfoundry Uaa-Release.

## How do I fix CVE-2017-8031?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.20.1, 4.5.3 or 4.7.1.

## Is CVE-2017-8031 being exploited?

There is no known exploitation of CVE-2017-8031 in the wild and no public exploit code.

## Other vulnerabilities in cf-release and UAA cf-release: All versions prior to v279, UAA: 30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1

- [CVE-2015-5171](https://insights.sbomify.com/CVE-2015-5171/): Cloud Foundry Runtime Insufficient Session Expiration vulnerability (critical 9.8)
- [CVE-2015-5172](https://insights.sbomify.com/CVE-2015-5172/): Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password (critical 9.8)
- [CVE-2016-8218](https://insights.sbomify.com/CVE-2016-8218/): Auth bypass in Cloud Foundry (critical 9.8)
- [CVE-2017-4992](https://insights.sbomify.com/CVE-2017-4992/): Cloud Foundry UAA privilege escalation with user invitations (critical 9.8)
- [CVE-2016-6658](https://insights.sbomify.com/CVE-2016-6658/): Information disclosure in n/a (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8031 and fix it if it is affected.

What it is: CVE-2017-8031 is a medium-severity missing authorization vulnerability in cf-release and UAA cf-release: All versions prior to v279, UAA: 30.x versions prior to 30.6, 45.x versions prior to 45.4, 52.x versions prior to 52.1, published on 27 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8031 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.20.1
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.20.1
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.0.0; fixed in 4.5.3
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.0.0; fixed in 4.5.3
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.6.0; fixed in 4.7.1
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.6.0; fixed in 4.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8031/ (Markdown: https://insights.sbomify.com/CVE-2017-8031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8031
- OSV: https://osv.dev/vulnerability/CVE-2017-8031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8031/
Summaries are generated and may contain mistakes; the official description above is the record.
