CVE-2017-8032 Cloud Foundry UAA Identity Zone Admin Privilege Escalation
Zone administrators can escalate privileges when mapping permissions for an external provider in Cloud Foundry UAA.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-8032?
CVE-2017-8032 is a medium-severity vulnerability in Cloud Foundry, published on 10 Jul 2017. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
In Cloud Foundry cf-release versions prior to v264; UAA release all versions of UAA v2.x.x, 3.6.x versions prior to v3.6.13, 3.9.x versions prior to v3.9.15, 3.20.x versions prior to v3.20.0, and other versions prior to v4.4.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.17, 24.x versions prior to v24.12. 30.x versions prior to 30.5, and other versions prior to v41, zone administrators are allowed to escalate their privileges when mapping permissions for an external provider.
Weakness: CWE-269
Which versions are affected by CVE-2017-8032?
8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 3.6.13 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 3.6.13 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.10.0 | 3.20.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.10.0 | 3.20.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.7.0 | 3.9.15 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 3.7.0 | 3.9.15 |
2 more packages
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.0.0 | 4.4.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.0.0 | 4.4.0 |
Products include Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Cf, Pivotal Software Cloud Foundry Uaa.
How do I fix CVE-2017-8032?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.6.13, 3.20.0, 3.9.15 or 4.4.0.
Is CVE-2017-8032 being exploited?
There is no known exploitation of CVE-2017-8032 in the wild and no public exploit code.
Other vulnerabilities in Cloud Foundry
Sources
Also known as GHSA-9frw-wmvq-5rrc.