# CVE-2017-8032: Cloud Foundry UAA Identity Zone Admin Privilege Escalation

> Zone administrators can escalate privileges when mapping permissions for an external provider in Cloud Foundry UAA.

- **Severity:** Medium 6.6 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9frw-wmvq-5rrc

## What is CVE-2017-8032?

CVE-2017-8032 is a medium-severity vulnerability in Cloud Foundry, published on 10 Jul 2017. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Cloud Foundry cf-release versions prior to v264; UAA release all versions of UAA v2.x.x, 3.6.x versions prior to v3.6.13, 3.9.x versions prior to v3.9.15, 3.20.x versions prior to v3.20.0, and other versions prior to v4.4.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.17, 24.x versions prior to v24.12. 30.x versions prior to 30.5, and other versions prior to v41, zone administrators are allowed to escalate their privileges when mapping permissions for an external provider.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2017-8032?

8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.6.13 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 3.6.13 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.20.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.10.0 | 3.20.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.15 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 3.7.0 | 3.9.15 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.0.0 | 4.4.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.0.0 | 4.4.0 |

Products: Cloudfoundry Cloud Foundry Uaa Bosh, Pivotal Software Cloud Foundry Cf, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2017-8032?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 3.6.13, 3.20.0, 3.9.15 or 4.4.0.

## Is CVE-2017-8032 being exploited?

There is no known exploitation of CVE-2017-8032 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry

- [CVE-2016-6637](https://insights.sbomify.com/CVE-2016-6637/): Cloud Foundry vulnerable to Cross-Site Request Forgery (critical 9.6)
- [CVE-2017-4973](https://insights.sbomify.com/CVE-2017-4973/): Cloud Foundry UAA Privilege Escalation (high 8.8)
- [CVE-2016-4468](https://insights.sbomify.com/CVE-2016-4468/): SQL injection in n/a (high 8.8)
- [CVE-2016-6651](https://insights.sbomify.com/CVE-2016-6651/): Privilege escalation in n/a (high 8.8)
- [CVE-2016-3084](https://insights.sbomify.com/CVE-2016-3084/): Cloud Foundry UAA reset password vulnerable to brute force attack (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8032 and fix it if it is affected.

What it is: CVE-2017-8032 is a medium-severity vulnerability in Cloud Foundry, published on 10 Jul 2017. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8032 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.6.13
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 3.6.13
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.20.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.10.0; fixed in 3.20.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.15
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.7.0; fixed in 3.9.15
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.0.0; fixed in 4.4.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.0.0; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8032/ (Markdown: https://insights.sbomify.com/CVE-2017-8032/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8032
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8032
- OSV: https://osv.dev/vulnerability/CVE-2017-8032

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8032/
Summaries are generated and may contain mistakes; the official description above is the record.
