{"answers":{"affected":"5 open source packages ship an affected version, including radicale and Radicale. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-8342 in the wild and no public exploit code.","fix":"Upgrade radicale to a fixed version for your release line: 1.1.2 or 2.0.0rc2.","what":"CVE-2017-8342 is a high-severity vulnerability in n/a, published on 30 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-8342 and fix it if it is affected.\n\nWhat it is: CVE-2017-8342 is a high-severity vulnerability in n/a, published on 30 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-8342 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- radicale (PyPI): affected all versions; fixed in 1.1.2\n- radicale (PyPI): affected all versions; fixed in 1.1.2\n- radicale (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc2\n- Radicale (PyPI): affected all versions; fixed in 1.1.2\n- Radicale (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-8342/ (Markdown: https://insights.sbomify.com/CVE-2017-8342/index.md)","id":"CVE-2017-8342","markdown":"https://insights.sbomify.com/CVE-2017-8342/index.md","name":"CVE-2017-8342","record":{"aliases":["DEBIAN-CVE-2017-8342","DLA-2187-1","DLA-934-1","GHSA-rpv4-63g3-9x23","MGASA-2017-0140","PYSEC-2017-102","UBUNTU-CVE-2017-8342"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"CalDAV/CardDAV server","requires_auth":"none","summary":"Radicale server exposes timing oracles in htpasswd authentication, allowing attackers to brute-force credentials and bypass security controls.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"radicale","vendor":"radicale"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Radicale is vulnerable to timing oracles and simple bruteforce attacks","id":"CVE-2017-8342","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":5,"n_references":5,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-8343"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"Radicale","purl":null,"source":"GHSA-rpv4-63g3-9x23"},{"ecosystem":"PyPI","fixed":["2.0.0rc2"],"introduced":["2.0.0rc1"],"last_affected":[],"package":"Radicale","purl":null,"source":"GHSA-rpv4-63g3-9x23"},{"ecosystem":"PyPI","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"radicale","purl":"pkg:pypi/radicale","source":"GHSA-rpv4-63g3-9x23"},{"ecosystem":"PyPI","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"radicale","purl":"pkg:pypi/radicale","source":"PYSEC-2017-102"},{"ecosystem":"PyPI","fixed":["2.0.0rc2"],"introduced":["2.0.0rc1"],"last_affected":[],"package":"radicale","purl":"pkg:pypi/radicale","source":"GHSA-rpv4-63g3-9x23"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-8341"},"products":["n/a"],"published":"2017-04-30","related":[{"cvss_score":10,"headline":"Radicale vulnerable to arbitrary file read or write","id":"CVE-2015-8747","kev_date_added":null,"published":"2016-02-03"},{"cvss_score":10,"headline":"Radicale is vulnerable to directory traversal on Windows Filesystem Storage Backend component","id":"CVE-2016-1505","kev_date_added":null,"published":"2016-02-03"},{"cvss_score":5.3,"headline":"Radicale regex metacharacters injection in the user name","id":"CVE-2015-8748","kev_date_added":null,"published":"2016-02-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Radicale server exposes timing oracles in htpasswd authentication, allowing attackers to brute-force credentials and bypass security controls.","url":"https://insights.sbomify.com/CVE-2017-8342/"}