# CVE-2017-8342: Radicale is vulnerable to timing oracles and simple bruteforce attacks

> Radicale server exposes timing oracles in htpasswd authentication, allowing attackers to brute-force credentials and bypass security controls.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-8342, DLA-2187-1, DLA-934-1, GHSA-rpv4-63g3-9x23, MGASA-2017-0140, PYSEC-2017-102, UBUNTU-CVE-2017-8342

## What is CVE-2017-8342?

CVE-2017-8342 is a high-severity vulnerability in n/a, published on 30 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Radicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2017-8342?

5 open source packages ship an affected version, including radicale and Radicale. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `radicale` | PyPI | All versions | 1.1.2 |
| `radicale` | PyPI | All versions | 1.1.2 |
| `radicale` | PyPI | From 2.0.0rc1 | 2.0.0rc2 |
| `Radicale` | PyPI | All versions | 1.1.2 |
| `Radicale` | PyPI | From 2.0.0rc1 | 2.0.0rc2 |

Products: Radicale Radicale.

## How do I fix CVE-2017-8342?

Upgrade radicale to a fixed version for your release line: 1.1.2 or 2.0.0rc2.

## Is CVE-2017-8342 being exploited?

There is no known exploitation of CVE-2017-8342 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-8747](https://insights.sbomify.com/CVE-2015-8747/): Radicale vulnerable to arbitrary file read or write (critical 10.0)
- [CVE-2016-1505](https://insights.sbomify.com/CVE-2016-1505/): Radicale is vulnerable to directory traversal on Windows Filesystem Storage Backend component (critical 10.0)
- [CVE-2015-8748](https://insights.sbomify.com/CVE-2015-8748/): Radicale regex metacharacters injection in the user name (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8342 and fix it if it is affected.

What it is: CVE-2017-8342 is a high-severity vulnerability in n/a, published on 30 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8342 in the wild and no public exploit code.

Affected packages and fixed versions:
- radicale (PyPI): affected all versions; fixed in 1.1.2
- radicale (PyPI): affected all versions; fixed in 1.1.2
- radicale (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc2
- Radicale (PyPI): affected all versions; fixed in 1.1.2
- Radicale (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8342/ (Markdown: https://insights.sbomify.com/CVE-2017-8342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8342
- OSV: https://osv.dev/vulnerability/CVE-2017-8342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8342/
Summaries are generated and may contain mistakes; the official description above is the record.
