# CVE-2017-8359: Use after free in n/a

> An out-of-bounds write via use-after-free in gRPC allows attackers to execute arbitrary code or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-8359, GHSA-j2fw-rfr9-pfrh, PYSEC-2017-101, UBUNTU-CVE-2017-8359

## What is CVE-2017-8359?

CVE-2017-8359 is a critical use after free vulnerability in n/a, published on 30 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Google gRPC before 2017-03-29 has an out-of-bounds write caused by a heap-based use-after-free related to the grpc_call_destroy function in core/lib/surface/call.c.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2017-8359?

1 open source package ship an affected version, including grpcio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grpcio` | PyPI | All versions | 1.3.0 |

Products: Grpc Grpc.

## How do I fix CVE-2017-8359?

Upgrade grpcio to 1.3.0 or later.

## Is CVE-2017-8359 being exploited?

There is no known exploitation of CVE-2017-8359 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-9431](https://insights.sbomify.com/CVE-2017-9431/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-7860](https://insights.sbomify.com/CVE-2017-7860/): Memory corruption in n/a (critical 9.8)
- [CVE-2017-7861](https://insights.sbomify.com/CVE-2017-7861/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-33186](https://insights.sbomify.com/CVE-2026-33186/): gRPC-Go has an authorization bypass via missing leading slash in :path (critical 9.1)
- [CVE-2023-4785](https://insights.sbomify.com/CVE-2023-4785/): Denial of Service in gRPC Core (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8359 and fix it if it is affected.

What it is: CVE-2017-8359 is a critical use after free vulnerability in n/a, published on 30 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8359 in the wild and no public exploit code.

Affected packages and fixed versions:
- grpcio (PyPI): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8359/ (Markdown: https://insights.sbomify.com/CVE-2017-8359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8359
- OSV: https://osv.dev/vulnerability/CVE-2017-8359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8359/
Summaries are generated and may contain mistakes; the official description above is the record.
