{"answers":{"affected":"2 open source packages ship an affected version, including genix/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-8376 in the wild and no public exploit code.","fix":"Upgrade genix/cms to 1.1.0 or later.","what":"CVE-2017-8376 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 May 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-8376 and fix it if it is affected.\n\nWhat it is: CVE-2017-8376 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 May 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-8376 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- genix/cms (Packagist): affected all versions; fixed in 1.1.0\n- genix/cms (Packagist): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-8376/ (Markdown: https://insights.sbomify.com/CVE-2017-8376/index.md)","id":"CVE-2017-8376","markdown":"https://insights.sbomify.com/CVE-2017-8376/index.md","name":"CVE-2017-8376","record":{"aliases":["GHSA-52xr-wx26-9rfg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"GeniXCMS","requires_auth":"low_privilege","summary":"An authenticated user can inject malicious scripts via comments that execute when an administrator interacts with them, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"genixcms","vendor":"genixcms"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GeniXCMS 1.0.2 has XSS triggered by an authenticated comment that is mishandled during a mouse operation by an administrator.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeniXCMS Cross-site Scripting (XSS)","id":"CVE-2017-8376","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"GeniXCMS SQL Injection","id":"CVE-2017-8377"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"genix/cms","purl":null,"source":"GHSA-52xr-wx26-9rfg"},{"ecosystem":"Packagist","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"genix/cms","purl":"pkg:composer/genix/cms","source":"GHSA-52xr-wx26-9rfg"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-8374"},"products":["n/a"],"published":"2017-05-01","related":[{"cvss_score":9.1,"headline":"GeniXCMS Arbitrary User Password Reset Vulnerability","id":"CVE-2017-8827","kev_date_added":null,"published":"2017-05-08"},{"cvss_score":8.8,"headline":"GeniXCMS arbitrary PHP code execution","id":"CVE-2017-14763","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":8.8,"headline":"GeniXCMS arbitrary PHP code execution","id":"CVE-2017-14764","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":8.8,"headline":"GeniXCMS SQL Injection","id":"CVE-2017-8377","kev_date_added":null,"published":"2017-05-01"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2015-2679","kev_date_added":null,"published":"2015-03-23"},{"cvss_score":7.3,"headline":"GeniXCMS SQL injection vulnerability","id":"CVE-2016-10096","kev_date_added":null,"published":"2017-01-01"},{"cvss_score":7.2,"headline":"GeniXCMS SQL injection vulnerability","id":"CVE-2017-5346","kev_date_added":null,"published":"2017-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An authenticated user can inject malicious scripts via comments that execute when an administrator interacts with them, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2017-8376/"}