# CVE-2017-8377: GeniXCMS SQL Injection

> SQL injection in GeniXCMS allows attackers to manipulate database queries via the menuid parameter, potentially exposing or altering data.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-34vw-8cjw-cwjj

## What is CVE-2017-8377?

CVE-2017-8377 is a high-severity SQL injection vulnerability in n/a, published on 1 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GeniXCMS 1.0.2 has SQL Injection in inc/lib/Control/Backend/menus.control.php via the menuid parameter.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-8377?

2 open source packages ship an affected version, including genix/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `genix/cms` | Packagist | All versions | 1.1.0 |
| `genix/cms` | Packagist | All versions | 1.1.0 |

Products: Genixcms Genixcms.

## How do I fix CVE-2017-8377?

Upgrade genix/cms to 1.1.0 or later.

## Is CVE-2017-8377 being exploited?

There is no known exploitation of CVE-2017-8377 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-8827](https://insights.sbomify.com/CVE-2017-8827/): GeniXCMS Arbitrary User Password Reset Vulnerability (critical 9.1)
- [CVE-2017-14763](https://insights.sbomify.com/CVE-2017-14763/): GeniXCMS arbitrary PHP code execution (high 8.8)
- [CVE-2017-14764](https://insights.sbomify.com/CVE-2017-14764/): GeniXCMS arbitrary PHP code execution (high 8.8)
- [CVE-2015-2679](https://insights.sbomify.com/CVE-2015-2679/): SQL injection in n/a (high 7.5)
- [CVE-2016-10096](https://insights.sbomify.com/CVE-2016-10096/): GeniXCMS SQL injection vulnerability (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8377 and fix it if it is affected.

What it is: CVE-2017-8377 is a high-severity SQL injection vulnerability in n/a, published on 1 May 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8377 in the wild and no public exploit code.

Affected packages and fixed versions:
- genix/cms (Packagist): affected all versions; fixed in 1.1.0
- genix/cms (Packagist): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8377/ (Markdown: https://insights.sbomify.com/CVE-2017-8377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8377
- OSV: https://osv.dev/vulnerability/CVE-2017-8377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8377/
Summaries are generated and may contain mistakes; the official description above is the record.
