# CVE-2017-8418: RuboCop gem Insecure use of /tmp

> Local attackers can tamper with cache files of other users due to unsafe temporary file handling in RuboCop.

- **Severity:** Low 3.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2017
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-8418, GHSA-wmjf-jpjj-9f3j

## What is CVE-2017-8418?

CVE-2017-8418 is a low-severity path traversal vulnerability in n/a, published on 2 May 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RuboCop 0.48.1 and earlier does not use /tmp in safe way, allowing local users to exploit this to tamper with cache files belonging to other users.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2017-8418?

2 open source packages ship an affected version, including rubocop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rubocop` | RubyGems | All versions | 0.49.0 |
| `rubocop` | RubyGems | All versions | 0.49.0 |

Products: Rubocop Project Rubocop.

## How do I fix CVE-2017-8418?

Upgrade rubocop to 0.49.0 or later.

## Is CVE-2017-8418 being exploited?

There is no known exploitation of CVE-2017-8418 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8418 and fix it if it is affected.

What it is: CVE-2017-8418 is a low-severity path traversal vulnerability in n/a, published on 2 May 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8418 in the wild and no public exploit code.

Affected packages and fixed versions:
- rubocop (RubyGems): affected all versions; fixed in 0.49.0
- rubocop (RubyGems): affected all versions; fixed in 0.49.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8418/ (Markdown: https://insights.sbomify.com/CVE-2017-8418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8418
- OSV: https://osv.dev/vulnerability/CVE-2017-8418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8418/
Summaries are generated and may contain mistakes; the official description above is the record.
