# CVE-2017-8446: Improper Privilege Management in X-Pack

> A user with the reporting_user role can impersonate another user to execute reports, potentially accessing sensitive data.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m728-qvxh-xfjq

## What is CVE-2017-8446?

CVE-2017-8446 is a medium-severity vulnerability in Elastic X-Pack Reporting, published on 18 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Reporting feature in X-Pack in versions prior to 5.5.2 and standalone Reporting plugin versions versions prior to 2.4.6 had an impersonation vulnerability. A user with the reporting_user role could execute a report with the permissions of another reporting user, possibly gaining access to sensitive data.

Weakness: CWE-269 (Improper Privilege Management), CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2017-8446?

2 open source packages ship an affected version, including org.elasticsearch.plugin:x-pack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch.plugin:x-pack` | Maven | All versions | 5.5.2 |
| `org.elasticsearch.plugin:x-pack` | Maven | All versions | 5.5.2 |

Products: Elasticsearch X-Pack, Elasticsearch X-Pack Reporting.

## How do I fix CVE-2017-8446?

Upgrade org.elasticsearch.plugin:x-pack to 5.5.2 or later.

## Is CVE-2017-8446 being exploited?

There is no known exploitation of CVE-2017-8446 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8446 and fix it if it is affected.

What it is: CVE-2017-8446 is a medium-severity vulnerability in Elastic X-Pack Reporting, published on 18 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8446 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch.plugin:x-pack (Maven): affected all versions; fixed in 5.5.2
- org.elasticsearch.plugin:x-pack (Maven): affected all versions; fixed in 5.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8446/ (Markdown: https://insights.sbomify.com/CVE-2017-8446/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8446
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8446
- OSV: https://osv.dev/vulnerability/CVE-2017-8446

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8446/
Summaries are generated and may contain mistakes; the official description above is the record.
