{"answers":{"affected":"2 open source packages ship an affected version, including genix/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-8780 in the wild and no public exploit code.","fix":"Upgrade genix/cms to 1.1.0 or later.","what":"CVE-2017-8780 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-8780 and fix it if it is affected.\n\nWhat it is: CVE-2017-8780 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-8780 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- genix/cms (Packagist): affected all versions; fixed in 1.1.0\n- genix/cms (Packagist): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-8780/ (Markdown: https://insights.sbomify.com/CVE-2017-8780/index.md)","id":"CVE-2017-8780","markdown":"https://insights.sbomify.com/CVE-2017-8780/index.md","name":"CVE-2017-8780","record":{"aliases":["GHSA-5hf2-7xf4-w3j6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"GeniXCMS","requires_auth":"high_privilege","summary":"An attacker can inject malicious scripts via comments that execute when an administrator publishes them, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"genixcms","vendor":"genixcms"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GeniXCMS 1.0.2 has XSS triggered by a comment that is mishandled during a publish operation by an administrator, as demonstrated by a malformed P element.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeniXCMS Cross-site Scripting","id":"CVE-2017-8780","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-8781"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"genix/cms","purl":null,"source":"GHSA-5hf2-7xf4-w3j6"},{"ecosystem":"Packagist","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"genix/cms","purl":"pkg:composer/genix/cms","source":"GHSA-5hf2-7xf4-w3j6"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2017-8779"},"products":["n/a"],"published":"2017-05-04","related":[{"cvss_score":9.1,"headline":"GeniXCMS Arbitrary User Password Reset Vulnerability","id":"CVE-2017-8827","kev_date_added":null,"published":"2017-05-08"},{"cvss_score":8.8,"headline":"GeniXCMS arbitrary PHP code execution","id":"CVE-2017-14763","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":8.8,"headline":"GeniXCMS arbitrary PHP code execution","id":"CVE-2017-14764","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":8.8,"headline":"GeniXCMS SQL Injection","id":"CVE-2017-8377","kev_date_added":null,"published":"2017-05-01"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2015-2679","kev_date_added":null,"published":"2015-03-23"},{"cvss_score":7.3,"headline":"GeniXCMS SQL injection vulnerability","id":"CVE-2016-10096","kev_date_added":null,"published":"2017-01-01"},{"cvss_score":7.2,"headline":"GeniXCMS SQL injection vulnerability","id":"CVE-2017-5346","kev_date_added":null,"published":"2017-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via comments that execute when an administrator publishes them, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2017-8780/"}