# CVE-2017-8780: GeniXCMS Cross-site Scripting

> An attacker can inject malicious scripts via comments that execute when an administrator publishes them, potentially leading to session hijacking or code execution.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 May 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-5hf2-7xf4-w3j6

## What is CVE-2017-8780?

CVE-2017-8780 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

GeniXCMS 1.0.2 has XSS triggered by a comment that is mishandled during a publish operation by an administrator, as demonstrated by a malformed P element.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-8780?

2 open source packages ship an affected version, including genix/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `genix/cms` | Packagist | All versions | 1.1.0 |
| `genix/cms` | Packagist | All versions | 1.1.0 |

Products: Genixcms Genixcms.

## How do I fix CVE-2017-8780?

Upgrade genix/cms to 1.1.0 or later.

## Is CVE-2017-8780 being exploited?

There is no known exploitation of CVE-2017-8780 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-8827](https://insights.sbomify.com/CVE-2017-8827/): GeniXCMS Arbitrary User Password Reset Vulnerability (critical 9.1)
- [CVE-2017-14763](https://insights.sbomify.com/CVE-2017-14763/): GeniXCMS arbitrary PHP code execution (high 8.8)
- [CVE-2017-14764](https://insights.sbomify.com/CVE-2017-14764/): GeniXCMS arbitrary PHP code execution (high 8.8)
- [CVE-2017-8377](https://insights.sbomify.com/CVE-2017-8377/): GeniXCMS SQL Injection (high 8.8)
- [CVE-2015-2679](https://insights.sbomify.com/CVE-2015-2679/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8780 and fix it if it is affected.

What it is: CVE-2017-8780 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-8780 in the wild and no public exploit code.

Affected packages and fixed versions:
- genix/cms (Packagist): affected all versions; fixed in 1.1.0
- genix/cms (Packagist): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8780/ (Markdown: https://insights.sbomify.com/CVE-2017-8780/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8780
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8780
- OSV: https://osv.dev/vulnerability/CVE-2017-8780

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8780/
Summaries are generated and may contain mistakes; the official description above is the record.
