{"answers":{"affected":"2 open source packages ship an affected version, including genix/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-8827 in the wild and no public exploit code.","fix":"Upgrade genix/cms to 1.1.2 or later.","what":"CVE-2017-8827 is a critical vulnerability in n/a, published on 8 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-8827 and fix it if it is affected.\n\nWhat it is: CVE-2017-8827 is a critical vulnerability in n/a, published on 8 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-8827 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- genix/cms (Packagist): affected all versions; fixed in 1.1.2\n- genix/cms (Packagist): affected all versions; fixed in 1.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-8827/ (Markdown: https://insights.sbomify.com/CVE-2017-8827/index.md)","id":"CVE-2017-8827","markdown":"https://insights.sbomify.com/CVE-2017-8827/index.md","name":"CVE-2017-8827","record":{"aliases":["GHSA-wm7g-rmgg-9837"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["denial_of_service","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"GeniXCMS","requires_auth":"none","summary":"Attackers can bypass rate limits on password reset requests to cause denial of service or reset arbitrary user passwords in GeniXCMS.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"genixcms","vendor":"genixcms"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"forgotpassword.php in GeniXCMS 1.0.2 lacks a rate limit, which might allow remote attackers to cause a denial of service (login inability) or possibly conduct Arbitrary User Password Reset attacks via a series of requests.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeniXCMS Arbitrary User Password Reset Vulnerability","id":"CVE-2017-8827","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Deserialization in n/a","id":"CVE-2017-8829"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"genix/cms","purl":null,"source":"GHSA-wm7g-rmgg-9837"},{"ecosystem":"Packagist","fixed":["1.1.2"],"introduced":["0"],"last_affected":[],"package":"genix/cms","purl":"pkg:composer/genix/cms","source":"GHSA-wm7g-rmgg-9837"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-8826"},"products":["n/a"],"published":"2017-05-08","related":[{"cvss_score":8.8,"headline":"GeniXCMS arbitrary PHP code execution","id":"CVE-2017-14763","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":8.8,"headline":"GeniXCMS arbitrary PHP code execution","id":"CVE-2017-14764","kev_date_added":null,"published":"2017-09-27"},{"cvss_score":8.8,"headline":"GeniXCMS SQL Injection","id":"CVE-2017-8377","kev_date_added":null,"published":"2017-05-01"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2015-2679","kev_date_added":null,"published":"2015-03-23"},{"cvss_score":7.3,"headline":"GeniXCMS SQL injection vulnerability","id":"CVE-2016-10096","kev_date_added":null,"published":"2017-01-01"},{"cvss_score":7.2,"headline":"GeniXCMS SQL injection vulnerability","id":"CVE-2017-5346","kev_date_added":null,"published":"2017-01-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass rate limits on password reset requests to cause denial of service or reset arbitrary user passwords in GeniXCMS.","url":"https://insights.sbomify.com/CVE-2017-8827/"}