# CVE-2017-8827: GeniXCMS Arbitrary User Password Reset Vulnerability

> Attackers can bypass rate limits on password reset requests to cause denial of service or reset arbitrary user passwords in GeniXCMS.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wm7g-rmgg-9837

## What is CVE-2017-8827?

CVE-2017-8827 is a critical vulnerability in n/a, published on 8 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

forgotpassword.php in GeniXCMS 1.0.2 lacks a rate limit, which might allow remote attackers to cause a denial of service (login inability) or possibly conduct Arbitrary User Password Reset attacks via a series of requests.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-8827?

2 open source packages ship an affected version, including genix/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `genix/cms` | Packagist | All versions | 1.1.2 |
| `genix/cms` | Packagist | All versions | 1.1.2 |

Products: Genixcms Genixcms.

## How do I fix CVE-2017-8827?

Upgrade genix/cms to 1.1.2 or later.

## Is CVE-2017-8827 being exploited?

There is no known exploitation of CVE-2017-8827 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-14763](https://insights.sbomify.com/CVE-2017-14763/): GeniXCMS arbitrary PHP code execution (high 8.8)
- [CVE-2017-14764](https://insights.sbomify.com/CVE-2017-14764/): GeniXCMS arbitrary PHP code execution (high 8.8)
- [CVE-2017-8377](https://insights.sbomify.com/CVE-2017-8377/): GeniXCMS SQL Injection (high 8.8)
- [CVE-2015-2679](https://insights.sbomify.com/CVE-2015-2679/): SQL injection in n/a (high 7.5)
- [CVE-2016-10096](https://insights.sbomify.com/CVE-2016-10096/): GeniXCMS SQL injection vulnerability (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8827 and fix it if it is affected.

What it is: CVE-2017-8827 is a critical vulnerability in n/a, published on 8 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8827 in the wild and no public exploit code.

Affected packages and fixed versions:
- genix/cms (Packagist): affected all versions; fixed in 1.1.2
- genix/cms (Packagist): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8827/ (Markdown: https://insights.sbomify.com/CVE-2017-8827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8827
- OSV: https://osv.dev/vulnerability/CVE-2017-8827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8827/
Summaries are generated and may contain mistakes; the official description above is the record.
