{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-8923 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-8923 is a critical vulnerability in Php Php, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-8923 and fix it if it is affected.\n\nWhat it is: CVE-2017-8923 is a critical vulnerability in Php Php, published on 12 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-8923 in the wild and no public exploit code.\n\nAffected product: Php Php. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-8923/ (Markdown: https://insights.sbomify.com/CVE-2017-8923/index.md)","id":"CVE-2017-8923","markdown":"https://insights.sbomify.com/CVE-2017-8923/index.md","name":"CVE-2017-8923","record":{"aliases":["CLSA-2025-1749743304","CLSA-2025-1749743798","CLSA-2026-1772120065","GHSA-wrc8-jp87-rq8j","SUSE-SU-2022:0530-1","SUSE-SU-2022:0699-1","UBUNTU-CVE-2017-8923","openSUSE-SU-2022:0699-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP interpreter","requires_auth":"none","summary":"Remote attackers can crash the PHP application by triggering a negative string length via integer overflow in zend_string_extend.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"The zend_string_extend function in Zend/zend_string.h in PHP through 7.1.5 does not prevent changes to string objects that result in a negative length, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact by leveraging a script's use of .= with a long string.","ecosystems":["SUSE:Linux Enterprise Module for Package Hub 15 SP3","SUSE:Linux Enterprise Module for Web and Scripting 12","SUSE:Linux Enterprise Module for Web and Scripting 15 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP5","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2017-8923","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"php:php","products":["php:php"],"type":"integer_overflow","year":"2017"},"n_packages":6,"n_references":2,"next":{"headline":"Integer overflow in n/a","id":"CVE-2017-8924"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP3","fixed":["7.4.6-3.32.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP3","source":"SUSE-SU-2022:0699-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["7.4.6-1.33.1"],"introduced":["0"],"last_affected":[],"package":"php74","purl":"pkg:rpm/suse/php74\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2022:0530-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 15 SP3","fixed":["7.4.6-3.32.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/suse/php7\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2015%20SP3","source":"SUSE-SU-2022:0699-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["7.4.6-1.33.1"],"introduced":["0"],"last_affected":[],"package":"php74","purl":"pkg:rpm/suse/php74\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2022:0530-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["7.4.6-3.32.1"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/opensuse/php7\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:0699-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["7.4.6-3.32.1"],"introduced":["0"],"last_affected":[],"package":"php7-test","purl":"pkg:rpm/opensuse/php7-test\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:0699-1"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2017-8921"},"products":["n/a"],"published":"2017-05-12","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-12-27","vendors":["n/a"]},"summary":"Remote attackers can crash the PHP application by triggering a negative string length via integer overflow in zend_string_extend.","url":"https://insights.sbomify.com/CVE-2017-8923/"}