# CVE-2017-8932: Other in n/a

> An adaptive attack on Go's P-256 ScalarMult implementation allows full private key recovery in static ECDH contexts, compromising JWT security.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-25hf-x7c8-5f3h, GO-2022-0187, MGASA-2017-0195, SUSE-RU-2017:1965-1, UBUNTU-CVE-2017-8932, openSUSE-SU-2017:1649-1, openSUSE-SU-2017:1650-1

## What is CVE-2017-8932?

CVE-2017-8932 is a medium-severity vulnerability in Fedoraproject Fedora, published on 6 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A bug in the standard library ScalarMult implementation of curve P-256 for amd64 architectures in Go before 1.7.6 and 1.8.x before 1.8.2 causes incorrect results to be generated for specific input points. An adaptive attack can be mounted to progressively extract the scalar input to ScalarMult by submitting crafted points and observing failures to the derive correct output. This leads to a full key recovery attack against static ECDH, as used in popular JWT libraries.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2017-8932?

1 open source package ship an affected version, including stdlib. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stdlib` | Go | From 1.6.0-0 | 1.7.6, 1.8.2 |
| `containerd` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.2.5+gitr639_422e31c-20.2 |
| `docker` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 17.04.0_ce-98.2 |
| `docker-distribution` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 2.6.1-15.2 |
| `golang-github-docker-libnetwork` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.0.0+git20170119.7b2b1fe-4.1 |
| `runc` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 0.1.1+gitr2947_9c2d8d1-20.3 |
| `containerd` | SUSE:OpenStack Cloud 6 | All versions | 0.2.5+gitr639_422e31c-20.2 |
| `docker` | SUSE:OpenStack Cloud 6 | All versions | 17.04.0_ce-98.2 |
| `golang-github-docker-libnetwork` | SUSE:OpenStack Cloud 6 | All versions | 0.0.0+git20170119.7b2b1fe-4.1 |
| `runc` | SUSE:OpenStack Cloud 6 | All versions | 0.1.1+gitr2947_9c2d8d1-20.3 |
| `go` | SUSE:Package Hub 12 | All versions | 1.7.0-12.1 |
| `go` | SUSE:Package Hub 12 | All versions | 1.7.0-12.1 |

Products: Fedoraproject Fedora, Golang Go, Novell Suse Package Hub for Suse Linux Enterprise, Opensuse Leap.

## How do I fix CVE-2017-8932?

Upgrade stdlib to a fixed version for your release line: 1.7.6 or 1.8.2.

## Is CVE-2017-8932 being exploited?

There is no known exploitation of CVE-2017-8932 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-8932 and fix it if it is affected.

What it is: CVE-2017-8932 is a medium-severity vulnerability in Fedoraproject Fedora, published on 6 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-8932 in the wild and no public exploit code.

Affected packages and fixed versions:
- stdlib (Go): affected from 1.6.0-0; fixed in 1.7.6, 1.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-8932/ (Markdown: https://insights.sbomify.com/CVE-2017-8932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-8932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-8932
- OSV: https://osv.dev/vulnerability/CVE-2017-8932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-8932/
Summaries are generated and may contain mistakes; the official description above is the record.
