{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9050 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.8.1 or later.","what":"CVE-2017-9050 is a high-severity memory corruption vulnerability in Xmlsoft Libxml2, published on 18 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-9050 and fix it if it is affected.\n\nWhat it is: CVE-2017-9050 is a high-severity memory corruption vulnerability in Xmlsoft Libxml2, published on 18 May 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-9050 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.8.1\n- nokogiri (RubyGems): affected all versions; fixed in 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9050/ (Markdown: https://insights.sbomify.com/CVE-2017-9050/index.md)","id":"CVE-2017-9050","markdown":"https://insights.sbomify.com/CVE-2017-9050/index.md","name":"CVE-2017-9050","record":{"aliases":["DEBIAN-CVE-2017-9050","ECHO-671f-1ea4-e79b","GHSA-8c56-cpmw-89x7","UBUNTU-CVE-2017-9050"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"XML parsing library","requires_auth":"none","summary":"A heap-based buffer over-read in libxml2 allows attackers to cause a denial of service via crafted XML input, affecting applications like PHP.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libxml2","vendor":"xmlsoft"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Out-of-bounds read in nokogiri","id":"CVE-2017-9050","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"xmlsoft:libxml2","products":["xmlsoft:libxml2"],"type":"memory_corruption","year":"2017"},"n_packages":2,"n_references":6,"next":{"headline":"Null dereference in n/a","id":"CVE-2017-9051"},"packages":[{"ecosystem":"RubyGems","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-8c56-cpmw-89x7"},{"ecosystem":"RubyGems","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-8c56-cpmw-89x7"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-9049"},"products":["n/a"],"published":"2017-05-18","related":[{"cvss_score":9.8,"headline":"XML external entity in n/a","id":"CVE-2017-16931","kev_date_added":null,"published":"2017-11-23"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2017-8872","kev_date_added":null,"published":"2017-05-10"},{"cvss_score":8.1,"headline":"Use after free in libxml2","id":"CVE-2022-49043","kev_date_added":null,"published":"2025-01-26"},{"cvss_score":8,"headline":"Memory corruption in libxml2","id":"CVE-2026-86140","kev_date_added":null,"published":"2026-09-05"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2024-34459","kev_date_added":null,"published":"2024-05-13"},{"cvss_score":7.5,"headline":"Use after free in n/a","id":"CVE-2024-25062","kev_date_added":null,"published":"2024-02-04"},{"cvss_score":7.5,"headline":"Nokogiri gem, via libxml, is affected by DoS vulnerabilities","id":"CVE-2017-16932","kev_date_added":null,"published":"2017-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-14","vendors":["n/a"]},"summary":"A heap-based buffer over-read in libxml2 allows attackers to cause a denial of service via crafted XML input, affecting applications like PHP.","url":"https://insights.sbomify.com/CVE-2017-9050/"}