CVE-2017-9067 MODX Revolution Directory Traversal Vulnerability
High 7.0
Published
Updated
Check this codebase for CVE-2017-9067 and fix it if it is affected.
What it is: CVE-2017-9067 is a high-severity vulnerability in Php Php, published on 18 May 2017.
Exploitation: There is no known exploitation of CVE-2017-9067 in the wild and no public exploit code.
Affected packages and fixed versions:
- modx/revolution (Packagist): affected all versions; fixed in 2.5.7
- modx/revolution (Packagist): affected all versions; fixed in 2.5.7
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2017-9067/ (Markdown: https://insights.sbomify.com/CVE-2017-9067/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2017-9067?
CVE-2017-9067 is a high-severity vulnerability in Php Php, published on 18 May 2017.
Official description
In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.
Weakness: CWE-22
Which versions are affected by CVE-2017-9067?
2 open source packages ship an affected version, including modx/revolution. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
modx/revolution Packagist | All versions | 2.5.7 |
modx/revolution Packagist | All versions | 2.5.7 |
Products include Modx Modx Revolution, Php Php.
How do I fix CVE-2017-9067?
Upgrade modx/revolution to 2.5.7 or later.
Is CVE-2017-9067 being exploited?
There is no known exploitation of CVE-2017-9067 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as GHSA-cgrv-6h2h-6f7v.