# CVE-2017-9067: MODX Revolution Directory Traversal Vulnerability


- **Severity:** High 7.0 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 May 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-cgrv-6h2h-6f7v

## What is CVE-2017-9067?

CVE-2017-9067 is a high-severity vulnerability in Php Php, published on 18 May 2017. 

### Official description

In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-9067?

2 open source packages ship an affected version, including modx/revolution. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modx/revolution` | Packagist | All versions | 2.5.7 |
| `modx/revolution` | Packagist | All versions | 2.5.7 |

Products: Modx Modx Revolution, Php Php.

## How do I fix CVE-2017-9067?

Upgrade modx/revolution to 2.5.7 or later.

## Is CVE-2017-9067 being exploited?

There is no known exploitation of CVE-2017-9067 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2017-7321](https://insights.sbomify.com/CVE-2017-7321/): Code injection in n/a (critical 9.8)
- [CVE-2017-7324](https://insights.sbomify.com/CVE-2017-7324/): Code injection in n/a (critical 9.8)
- [CVE-2020-25911](https://insights.sbomify.com/CVE-2020-25911/): XML External Entity vulnerability in MODX CMS (critical 9.1)
- [CVE-2017-9069](https://insights.sbomify.com/CVE-2017-9069/): MODX Revolution allows overwriting .htaccess (high 8.8)
- [CVE-2017-7322](https://insights.sbomify.com/CVE-2017-7322/): Weak cryptography in n/a (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9067 and fix it if it is affected.

What it is: CVE-2017-9067 is a high-severity vulnerability in Php Php, published on 18 May 2017. 
Exploitation: There is no known exploitation of CVE-2017-9067 in the wild and no public exploit code.

Affected packages and fixed versions:
- modx/revolution (Packagist): affected all versions; fixed in 2.5.7
- modx/revolution (Packagist): affected all versions; fixed in 2.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9067/ (Markdown: https://insights.sbomify.com/CVE-2017-9067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9067
- OSV: https://osv.dev/vulnerability/CVE-2017-9067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9067/
Summaries are generated and may contain mistakes; the official description above is the record.
