{"answers":{"affected":"2 open source packages ship an affected version, including modx/revolution. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9071 in the wild and no public exploit code.","fix":"Upgrade modx/revolution to 2.5.7 or later.","what":"CVE-2017-9071 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-9071 and fix it if it is affected.\n\nWhat it is: CVE-2017-9071 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-9071 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modx/revolution (Packagist): affected all versions; fixed in 2.5.7\n- modx/revolution (Packagist): affected all versions; fixed in 2.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9071/ (Markdown: https://insights.sbomify.com/CVE-2017-9071/index.md)","id":"CVE-2017-9071","markdown":"https://insights.sbomify.com/CVE-2017-9071/index.md","name":"CVE-2017-9071","record":{"aliases":["GHSA-p2j4-vrgx-96qg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"MODX Revolution CMS","requires_auth":"none","summary":"Attackers can inject scripts via HTTP Host header in MODX Revolution, requiring cache poisoning for exploitation, leading to potential code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"modx_revolution","vendor":"modx"}],"cvss":{"score":4.7,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In MODX Revolution before 2.5.7, an attacker might be able to trigger XSS by injecting a payload into the HTTP Host header of a request. This is exploitable only in conjunction with other issues such as Cache Poisoning.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MODX Revolution XSS via HTTP Host header","id":"CVE-2017-9071","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-9072"},"packages":[{"ecosystem":"Packagist","fixed":["2.5.7"],"introduced":["0"],"last_affected":[],"package":"modx/revolution","purl":null,"source":"GHSA-p2j4-vrgx-96qg"},{"ecosystem":"Packagist","fixed":["2.5.7"],"introduced":["0"],"last_affected":[],"package":"modx/revolution","purl":"pkg:composer/modx/revolution","source":"GHSA-p2j4-vrgx-96qg"}],"prev":{"headline":"MODX Revolution cross-site scripting vulnerability","id":"CVE-2017-9070"},"products":["n/a"],"published":"2017-05-18","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2017-7321","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2017-7324","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":9.1,"headline":"XML External Entity vulnerability in MODX CMS","id":"CVE-2020-25911","kev_date_added":null,"published":"2021-10-31"},{"cvss_score":8.8,"headline":"MODX Revolution allows overwriting .htaccess","id":"CVE-2017-9069","kev_date_added":null,"published":"2017-05-18"},{"cvss_score":8.1,"headline":"Weak cryptography in n/a","id":"CVE-2017-7322","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":8.1,"headline":"Server-side request forgery in n/a","id":"CVE-2017-7323","kev_date_added":null,"published":"2017-03-30"},{"cvss_score":7.5,"headline":"File upload in Gallery","id":"CVE-2019-1010123","kev_date_added":null,"published":"2019-07-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can inject scripts via HTTP Host header in MODX Revolution, requiring cache poisoning for exploitation, leading to potential code execution.","url":"https://insights.sbomify.com/CVE-2017-9071/"}