CVE-2017-9096 Improper Restriction of XML External Entity Reference in iText
Remote attackers can exploit XML external entity vulnerabilities in iText PDF parsers to read sensitive data or cause denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-9096?
CVE-2017-9096 is a high-severity vulnerability in n/a, published on 8 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The XML parsers in iText before 5.5.12 and 7.x before 7.0.3 do not disable external entities, which might allow remote attackers to conduct XML external entity (XXE) attacks via a crafted PDF.
Weakness: CWE-611
Which versions are affected by CVE-2017-9096?
6 open source packages ship an affected version, including com.itextpdf:itextpdf and com.lowagie:itext. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.itextpdf:itextpdf Maven | All versions | 5.5.12 |
com.itextpdf:itextpdf Maven | All versions | 5.5.12 |
com.itextpdf:itextpdf Maven | From 7.0.0 | 7.0.3 |
com.itextpdf:itextpdf Maven | From 7.0.0 | 7.0.3 |
com.lowagie:itext Maven | All versions to 4.2.2 | None |
com.lowagie:itext Maven | All versions to 4.2.2 | None |
Products include Itextpdf Itext.
How do I fix CVE-2017-9096?
Upgrade com.itextpdf:itextpdf to a fixed version for your release line: 5.5.12 or 7.0.3.
Is CVE-2017-9096 being exploited?
There is no known exploitation of CVE-2017-9096 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in n/a
Sources
Also known as CLSA-2025-1761005191, CLSA-2026-1787125497, CLSA-2026-1787667201, GHSA-86p9-x5pw-94qx.