{"answers":{"affected":"3 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9111 in the wild and no public exploit code.","fix":"Upgrade openexr to 2.2.1 or later.","what":"CVE-2017-9111 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 21 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-9111 and fix it if it is affected.\n\nWhat it is: CVE-2017-9111 is a high-severity memory corruption vulnerability in Openexr Openexr, published on 21 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-9111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openexr (PyPI): affected all versions; fixed in 2.2.1\n- openexr (PyPI): affected all versions; fixed in 2.2.1\n- OpenEXR (PyPI): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9111/ (Markdown: https://insights.sbomify.com/CVE-2017-9111/index.md)","id":"CVE-2017-9111","markdown":"https://insights.sbomify.com/CVE-2017-9111/index.md","name":"CVE-2017-9111","record":{"aliases":["DEBIAN-CVE-2017-9111","GHSA-qxh9-r8xw-7v99","PYSEC-2026-728","UBUNTU-CVE-2017-9111"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenEXR image library","requires_auth":"none","summary":"An invalid write in OpenEXR allows attackers to crash the application or execute arbitrary code via crafted image files.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openexr","vendor":"openexr"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"In OpenEXR 2.2.0, an invalid write of size 8 in the storeSSE function in ImfOptimizedPixelReading.h could cause the application to crash or execute arbitrary code.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenEXR invalid write","id":"CVE-2017-9111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"openexr:openexr","products":["openexr:openexr"],"type":"memory_corruption","year":"2017"},"n_packages":3,"n_references":10,"next":{"headline":"OpenEXR invalid read","id":"CVE-2017-9112"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"OpenEXR","purl":null,"source":"GHSA-qxh9-r8xw-7v99"},{"ecosystem":"PyPI","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"openexr","purl":"pkg:pypi/openexr","source":"GHSA-qxh9-r8xw-7v99"},{"ecosystem":"PyPI","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"openexr","purl":"pkg:pypi/openexr","source":"PYSEC-2026-728"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2017-9110"},"products":["n/a"],"published":"2017-05-21","related":[{"cvss_score":9.1,"headline":"OpenEXR Heap Overflow in Scanline Deep Data Parsing","id":"CVE-2023-5841","kev_date_added":null,"published":"2024-02-01"},{"cvss_score":8.8,"headline":"OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API","id":"CVE-2026-41142","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":8.8,"headline":"OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion","id":"CVE-2026-42216","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2017-9113","kev_date_added":null,"published":"2017-05-21"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2017-9115","kev_date_added":null,"published":"2017-05-21"},{"cvss_score":8.7,"headline":"OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)","id":"CVE-2026-34543","kev_date_added":null,"published":"2026-04-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An invalid write in OpenEXR allows attackers to crash the application or execute arbitrary code via crafted image files.","url":"https://insights.sbomify.com/CVE-2017-9111/"}