# CVE-2017-9112: OpenEXR invalid read

> An invalid read in OpenEXR can crash applications processing malicious images, requiring an upgrade to the library.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 May 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-9112, GHSA-8m57-j273-2qg9, PYSEC-2026-727, UBUNTU-CVE-2017-9112

## What is CVE-2017-9112?

CVE-2017-9112 is a medium-severity denial of service vulnerability in Openexr Openexr, published on 21 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In OpenEXR 2.2.0, an invalid read of size 1 in the getBits function in ImfHuf.cpp could cause the application to crash.

## Which versions are affected by CVE-2017-9112?

3 open source packages ship an affected version, including openexr and OpenEXR. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openexr` | PyPI | All versions | 2.2.1 |
| `openexr` | PyPI | All versions | 2.2.1 |
| `OpenEXR` | PyPI | All versions | 2.2.1 |

Products: Openexr Openexr.

## How do I fix CVE-2017-9112?

Upgrade openexr to 2.2.1 or later.

## Is CVE-2017-9112 being exploited?

There is no known exploitation of CVE-2017-9112 in the wild and no public exploit code.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9112 and fix it if it is affected.

What it is: CVE-2017-9112 is a medium-severity denial of service vulnerability in Openexr Openexr, published on 21 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-9112 in the wild and no public exploit code.

Affected packages and fixed versions:
- openexr (PyPI): affected all versions; fixed in 2.2.1
- openexr (PyPI): affected all versions; fixed in 2.2.1
- OpenEXR (PyPI): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9112/ (Markdown: https://insights.sbomify.com/CVE-2017-9112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9112
- OSV: https://osv.dev/vulnerability/CVE-2017-9112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9112/
Summaries are generated and may contain mistakes; the official description above is the record.
