{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9270 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-9270 is a high-severity path traversal vulnerability in SUSE cryptctl, published on 1 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-9270 and fix it if it is affected.\n\nWhat it is: CVE-2017-9270 is a high-severity path traversal vulnerability in SUSE cryptctl, published on 1 Mar 2018. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-9270 in the wild and no public exploit code.\n\nAffected product: SUSE cryptctl. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9270/ (Markdown: https://insights.sbomify.com/CVE-2017-9270/index.md)","id":"CVE-2017-9270","markdown":"https://insights.sbomify.com/CVE-2017-9270/index.md","name":"CVE-2017-9270","record":{"aliases":["GHSA-whc2-8cpp-f5cp","SUSE-SU-2017:1865-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"cryptctl server","requires_auth":"high_privilege","summary":"A malicious server can send RPC requests to overwrite files outside the key database, allowing arbitrary file modification.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"cryptctl","vendor":"opensuse"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"In cryptctl before version 2.0 a malicious server could send RPC requests that could overwrite files outside of the cryptctl key database.","ecosystems":["SUSE:Linux Enterprise Server for SAP Applications 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"post-auth arbitrary file write on cryptctl server","id":"CVE-2017-9270","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2017"},"n_packages":1,"n_references":3,"next":{"headline":"proxy credentials written to log files by zypper","id":"CVE-2017-9271"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["1.2.6-5.3.11"],"introduced":["0"],"last_affected":[],"package":"cryptctl","purl":"pkg:rpm/suse/cryptctl\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2017:1865-1"}],"prev":{"headline":"lack of keypinning in libzypp could lead to repository switching","id":"CVE-2017-9269"},"products":["cryptctl"],"published":"2018-03-01","related":[{"cvss_score":9.8,"headline":"cryptctl: client side password hashing is equivalent to clear text password storage","id":"CVE-2019-18906","kev_date_added":null,"published":"2021-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["SUSE"]},"summary":"A malicious server can send RPC requests to overwrite files outside the key database, allowing arbitrary file modification.","url":"https://insights.sbomify.com/CVE-2017-9270/"}