{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9274 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-9274 is a high-severity command injection vulnerability in SUSE obs-service-source_validator, published on 1 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-9274 and fix it if it is affected.\n\nWhat it is: CVE-2017-9274 is a high-severity command injection vulnerability in SUSE obs-service-source_validator, published on 1 Mar 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-9274 in the wild and no public exploit code.\n\nAffected product: SUSE obs-service-source_validator. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9274/ (Markdown: https://insights.sbomify.com/CVE-2017-9274/index.md)","id":"CVE-2017-9274","markdown":"https://insights.sbomify.com/CVE-2017-9274/index.md","name":"CVE-2017-9274","record":{"aliases":["DEBIAN-CVE-2017-9274","GHSA-rmgp-j5rm-7ghv","UBUNTU-CVE-2017-9274","openSUSE-SU-2024:11106-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"SUSE OBS service","requires_auth":"none","summary":"Attackers can execute arbitrary shell commands as the packager by crafting malicious RPM SPEC files processed by the source validator service.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"obs-service-source_validator","vendor":"opensuse"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"A shell command injection in the obs-service-source_validator before 0.7 could be used to execute code as the packager when checking RPM SPEC files with specific macro constructs.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"osc executes spec code during \"osc commit\"","id":"CVE-2017-9274","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":1,"n_references":3,"next":{"headline":"NetIQ Identity Reporting XSS exposure","id":"CVE-2017-9275"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.21-1.3"],"introduced":["0"],"last_affected":[],"package":"obs-service-source_validator","purl":"pkg:rpm/opensuse/obs-service-source_validator\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11106-1"}],"prev":{"headline":"Missing authorization in IDM 4.5 bidirectional eDir Driver Version","id":"CVE-2017-9273"},"products":["obs-service-source_validator"],"published":"2018-03-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["SUSE"]},"summary":"Attackers can execute arbitrary shell commands as the packager by crafting malicious RPM SPEC files processed by the source validator service.","url":"https://insights.sbomify.com/CVE-2017-9274/"}