{"answers":{"affected":"10 open source packages ship an affected version, including illuminate/auth, laravel/framework and laravel/laravel. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-9303 in the wild and no public exploit code.","fix":"Upgrade illuminate/auth to 5.4.22 or later.","what":"CVE-2017-9303 is a medium-severity vulnerability in n/a, published on 29 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-9303 and fix it if it is affected.\n\nWhat it is: CVE-2017-9303 is a medium-severity vulnerability in n/a, published on 29 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-9303 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- illuminate/auth (Packagist): affected from 5.3.0 up to 5.3.31; no fix listed\n- illuminate/auth (Packagist): affected from 5.3.0 up to 5.3.31; no fix listed\n- illuminate/auth (Packagist): affected from 5.4.0; fixed in 5.4.22\n- illuminate/auth (Packagist): affected from 5.4.0; fixed in 5.4.22\n- laravel/framework (Packagist): affected from 5.3.0 up to 5.3.31; no fix listed\n- laravel/framework (Packagist): affected from 5.3.0 up to 5.3.31; no fix listed\n- laravel/framework (Packagist): affected from 5.4.0; fixed in 5.4.22\n- laravel/framework (Packagist): affected from 5.4.0; fixed in 5.4.22\n- laravel/laravel (Packagist): affected from 5.4.0; fixed in 5.4.22\n- laravel/laravel (Packagist): affected from 5.4.0; fixed in 5.4.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-9303/ (Markdown: https://insights.sbomify.com/CVE-2017-9303/index.md)","id":"CVE-2017-9303","markdown":"https://insights.sbomify.com/CVE-2017-9303/index.md","name":"CVE-2017-9303","record":{"aliases":["GHSA-rc8x-jrrc-frfv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel framework","requires_auth":"none","summary":"Attackers can manipulate password-reset URLs to redirect users to malicious hosts, facilitating phishing attacks against Laravel applications.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"laravel","vendor":"laravel"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Laravel does not properly constrain the host portion of a password-reset URL","id":"CVE-2017-9303","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"open_redirect","year":"2017"},"n_packages":10,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-9304"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["5.3.0"],"last_affected":["5.3.31"],"package":"illuminate/auth","purl":null,"source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":[],"introduced":["5.3.0"],"last_affected":["5.3.31"],"package":"illuminate/auth","purl":"pkg:composer/illuminate/auth","source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":["5.4.22"],"introduced":["5.4.0"],"last_affected":[],"package":"illuminate/auth","purl":null,"source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":["5.4.22"],"introduced":["5.4.0"],"last_affected":[],"package":"illuminate/auth","purl":"pkg:composer/illuminate/auth","source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":[],"introduced":["5.3.0"],"last_affected":["5.3.31"],"package":"laravel/framework","purl":null,"source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":[],"introduced":["5.3.0"],"last_affected":["5.3.31"],"package":"laravel/framework","purl":"pkg:composer/laravel/framework","source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":["5.4.22"],"introduced":["5.4.0"],"last_affected":[],"package":"laravel/framework","purl":null,"source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":["5.4.22"],"introduced":["5.4.0"],"last_affected":[],"package":"laravel/framework","purl":"pkg:composer/laravel/framework","source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":["5.4.22"],"introduced":["5.4.0"],"last_affected":[],"package":"laravel/laravel","purl":null,"source":"GHSA-rc8x-jrrc-frfv"},{"ecosystem":"Packagist","fixed":["5.4.22"],"introduced":["5.4.0"],"last_affected":[],"package":"laravel/laravel","purl":"pkg:composer/laravel/laravel","source":"GHSA-rc8x-jrrc-frfv"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2017-9302"},"products":["n/a"],"published":"2017-05-29","related":[{"cvss_score":8.1,"headline":"Laravel Deserialization of Untrusted Data","id":"CVE-2018-15133","kev_date_added":"2024-01-16","published":"2018-08-09"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2021-28254","kev_date_added":null,"published":"2023-04-18"},{"cvss_score":7.5,"headline":"Guard bypass in Eloquent models affecting Laravel illuminate database component","id":"CVE-2020-24940","kev_date_added":null,"published":"2020-09-04"},{"cvss_score":7.5,"headline":"Improper Input Validation in Laravel","id":"CVE-2020-24941","kev_date_added":null,"published":"2020-09-04"},{"cvss_score":7.5,"headline":"Information disclosure in n/a","id":"CVE-2017-16894","kev_date_added":null,"published":"2017-11-20"},{"cvss_score":7.2,"headline":"Query Binding Exploitation in Laravel","id":"CVE-2021-21263","kev_date_added":null,"published":"2021-01-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can manipulate password-reset URLs to redirect users to malicious hosts, facilitating phishing attacks against Laravel applications.","url":"https://insights.sbomify.com/CVE-2017-9303/"}