CVE-2017-9313 Cross-site scripting in n/a

Medium 6.1 Published Updated

Remote attackers can inject arbitrary web script or HTML via specific parameters in Webmin, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-9313?

CVE-2017-9313 is a medium-severity cross-site scripting vulnerability in Webmin Webmin, published on 4 Jul 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Multiple Cross-site scripting (XSS) vulnerabilities in Webmin before 1.850 allow remote attackers to inject arbitrary web script or HTML via the sec parameter to view_man.cgi, the referers parameter to change_referers.cgi, or the name parameter to save_user.cgi. NOTE: these issues were not fixed in 1.840.

Weakness: CWE-79

Which versions are affected by CVE-2017-9313?

It affects 1 product.

Products include Webmin Webmin.

How do I fix CVE-2017-9313?

No fix has been published for CVE-2017-9313 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-9313 being exploited?

There is no known exploitation of CVE-2017-9313 in the wild and no public exploit code.

All Webmin Webmin vulnerabilities

Sources

Also known as GHSA-93m5-952c-4mxx.

Is CVE-2017-9313 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free