# CVE-2017-9435: Dolibarr ERP and CRM SQLi

> Attackers can execute arbitrary SQL commands via the search_supervisor and search_statut parameters in Dolibarr ERP/CRM.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-v3m8-7h3p-6j5m, UBUNTU-CVE-2017-9435

## What is CVE-2017-9435?

CVE-2017-9435 is a critical SQL injection vulnerability in n/a, published on 5 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dolibarr ERP/CRM before 5.0.3 is vulnerable to a SQL injection in user/index.php (search_supervisor and search_statut parameters).

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2017-9435?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 5.0.3 |
| `dolibarr/dolibarr` | Packagist | All versions | 5.0.3 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2017-9435?

Upgrade dolibarr/dolibarr to 5.0.3 or later.

## Is CVE-2017-9435 being exploited?

There is no known exploitation of CVE-2017-9435 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-9435 and fix it if it is affected.

What it is: CVE-2017-9435 is a critical SQL injection vulnerability in n/a, published on 5 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-9435 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 5.0.3
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-9435/ (Markdown: https://insights.sbomify.com/CVE-2017-9435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-9435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-9435
- OSV: https://osv.dev/vulnerability/CVE-2017-9435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-9435/
Summaries are generated and may contain mistakes; the official description above is the record.
