CVE-2017-9735 Jetty vulnerable to exposure of sensitive information due to observable discrepancy
Remote attackers can exploit a timing channel in Jetty's password verification to infer correct passwords and gain unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-9735?
CVE-2017-9735 is a high-severity vulnerability in Debian Debian Linux, published on 16 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jetty through 9.4.x is prone to a timing channel in util/security/Password.java, which makes it easier for remote attackers to obtain access by observing elapsed times before rejection of incorrect passwords.
Weakness: CWE-203
Which versions are affected by CVE-2017-9735?
6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.jetty:jetty-server Maven | All versions | 9.2.22.v20170606 |
org.eclipse.jetty:jetty-server Maven | All versions | 9.2.22.v20170606 |
org.eclipse.jetty:jetty-server Maven | From 9.3.0 | 9.3.20.v20170531 |
org.eclipse.jetty:jetty-server Maven | From 9.3.0 | 9.3.20.v20170531 |
org.eclipse.jetty:jetty-server Maven | From 9.4.0 | 9.4.6.v20170531 |
org.eclipse.jetty:jetty-server Maven | From 9.4.0 | 9.4.6.v20170531 |
Products include Debian Debian Linux, Eclipse Jetty, Oracle Communications Cloud Native Core Policy, Oracle Enterprise Manager Base Platform, Oracle Hospitality Guest Access, Oracle Rest Data Services and 1 more.
How do I fix CVE-2017-9735?
Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.2.22.v20170606, 9.3.20.v20170531 or 9.4.6.v20170531.
Is CVE-2017-9735 being exploited?
There is no known exploitation of CVE-2017-9735 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-BA58800, DEBIAN-CVE-2017-9735, DLA-1020-1, DLA-1021-1, GHSA-wfcc-pff6-rgc5, MGASA-2017-0277 and 1 more.